problem installing Experience Builder Developer Edition 1.0

252
4
Jump to solution
04-05-2020 06:23 PM
New Contributor II

Hello All,

I'm having problem getting Experience Builder 1.0 installed.  Installed the node modules (using node v10.18.1). When I run "npm start" and go to https://localhost:3001, I get this from Chrome:

"localhost normally uses encryption to protect your information. When Google Chrome tried to connect to localhost this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be localhost, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Google Chrome stopped the connection before any data was exchanged.

You cannot visit localhost right now because the website sent scrambled credentials that Google Chrome cannot process. Network errors and attacks are usually temporary, so this page will probably work later."

I understand it's using a self-signed cert but this is new to me.  I was able to run the beta version w/o issues on this Mac (version 10.15.3).

Can anyone suggest a solution?

Thanks!

--john

Reply
0 Kudos
1 Solution

Accepted Solutions
Esri Regular Contributor

Hi John,

Open chrome://flags/#allow-insecure-localhost in address bar and enable the setting, then restart Chrome. I tested this with one of my colleagues who have macOC Catalina installed and local host worked as expected. We will have to update the doc for users on Catalina. Let me know if this works for you.

Cheers,

David

View solution in original post

Reply
0 Kudos
4 Replies
MVP Esteemed Contributor

Just in case you haven't see the notes

ArcGIS Experience Builder install | ArcGIS Experience Builder 

and requirements

Requirements | ArcGIS Experience Builder 

None of the bugs seem relevant

https://support.esri.com/en/Search-Results#search?q=%22experience%20builder%22&content-type=Bugs

Most recent blog about the final release, in case you haven't seen it

ArcGIS Experience Builder Developer Edition Final Release 

And last, perhapsJianxia Song‌ will have a shorter more concise answer

Reply
0 Kudos
New Contributor II

Thanks Dan. I have been through these docs and re-installed a couple of

times with no success.

--john

Reply
0 Kudos
Esri Regular Contributor

Hi John,

Open chrome://flags/#allow-insecure-localhost in address bar and enable the setting, then restart Chrome. I tested this with one of my colleagues who have macOC Catalina installed and local host worked as expected. We will have to update the doc for users on Catalina. Let me know if this works for you.

Cheers,

David

View solution in original post

Reply
0 Kudos
New Contributor II

Thanks David, that worked perfectly!

--john

Reply
0 Kudos