TypeError: Can not read property "100" of undefined Menu Widget ArcGIS Experience Builder

478
4
03-30-2020 04:12 AM
HasanHöl
New Contributor II

Hi Everyone,
   I am new user about ArcGIS Experience Builder and I am trying to understand how to build an app. I have a problem about using Menu widget and I do not understand what the problem is. I am getting the "Cannot read property '100' of undefined" in Experience Builder while trying to edit menu widget.

   I am using "Public Info" template and "General" template and also I tried other all templates. My implementation steps are that I added my pages and then add menu widget in the header.Then I am trying to make active "Advanced" part in the "Content" section. "Cannot read property '100' of undefined" message appeared in the section. Also I attached screenshot. How can I solve this error?

Any solution will be greatly appreciated.

Thank you for helping,

Hasan.

0 Kudos
4 Replies
DavidMartinez
Esri Regular Contributor

Hi Hasan,

Could you help us out and provide the exact steps you took to produce this error? I created an experience with multiple pages and tried to replicate, but I was not successful. 

Thanks,

David

0 Kudos
HasanHöl
New Contributor II

Hi David,

I made a short video about the error I encountered. Also I encountered the same error on experience.arcgis.com and I could not understand why I got this error, I am stuck.


I hope you can help me.

Thank you,

Hasan.

0 Kudos
DavidMartinez
Esri Regular Contributor

Hi Hasan,

Thank you for making this video. My colleague and I both tried your workflow and we weren't able to reproduce the error. What version of chrome are you using and bit? Also, can you try to reproduce the error in FireFox, Safari, or the new Microsoft Edge? 

David

0 Kudos
HasanHöl
New Contributor II

Hi David,

After your suggestion, I checked Chrome version. It was up to date and it's language was Turkish version. Then I realized that this error may be due to using Chrome in Turkish language. After changing language of Chrome, Menu widget ran properly. I can customize menu on properly. Maybe later I can use Experience Builder with Chrome in Turkish language.

I think this error is solved for now .

Thank you for helping and guidance.

Have nice and healthy days without coronavirus

Hasan.