Select to view content in your preferred language

Timeline widget - No added data can be used. Using Living Atlas Ocean Layers

1786
6
01-31-2023 09:54 AM
Labels (1)
kmsmikrud
Regular Contributor

Hello,

I was trying to add the Timeline widget to an EXB app and when I select the web map I get a message, "No added data can be used. Please add data." 

Layers in the map include a number of time-enabled layers from the Living Atlas such as Sea Surface Temperature which currently works in an WAB with the time-slider. There are few other Living Atlas layers that are imagery layers from Esri.

Are these not supported yet in EB?

Thanks,
Kathy

6 Replies
TonghuiMing
Esri Regular Contributor

@kmsmikrud I tried to search a living atlas layer with the keyword 'Sea Surface Temperature', and it does work:

TonghuiMing_0-1675233479674.png

Not sure what happened in your case. Care to share the problematic data here? Thanks.

0 Kudos
kmsmikrud
Regular Contributor

Hi TonghuiMing,

thanks for taking the time to test out. I'm wondering I notice above that the Living Atlas data is feature layer instead of imagery layer, would that make a difference?

I've attached a screenshot of the data I was trying to use. 

Thanks,

Kathy

0 Kudos
TonghuiMing
Esri Regular Contributor

@kmsmikrud Hi Kathy - The Timeline widget only supports three types of data:

 


The data source can be a web map, one or multiple map services, or one or multiple feature layers. 


https://doc.arcgis.com/en/experience-builder/latest/configure-widgets/timeline-widget.htm#ESRI_SECTI... 

0 Kudos
kmsmikrud
Regular Contributor

Thanks @TonghuiMing,

Currently the imagery layer works in WAB with the time-slider widget so is it on purpose that it won't work in the timeline widget in Experience Builder?

The data is temporal and time-enabled. Hopefully I am missing something but I'm using WAB as a work around.

TonghuiMing
Esri Regular Contributor

@kmsmikrud It is more of a framework-level issue than widget controlling matter since Experience Builder has not yet supported image service layers as one of the supported data source types. There are a few similar requests on that and feel free to follow up on them:

https://community.esri.com/t5/arcgis-experience-builder-ideas/enhance-filter-widget-to-recognise-mos...

https://community.esri.com/t5/arcgis-experience-builder-questions/is-there-a-time-slider-widget-for-...

ENH-000143692

ENH-000153737

Laura
by MVP Regular Contributor
MVP Regular Contributor

I am also getting this error, but on a web map and feature layer. They come from a collaboration.. is that a problem?