Possible solution if the EXB download fails

3392
18
Jump to solution
07-29-2023 08:06 PM
DavidDas__GISP
Occasional Contributor II

 

 

You may have run into this issue where you are attempting to Download a ZIP file of your Experience Builder Developer Project.

 

DavidDas__GISP_0-1690686267451.png

 

 

The download process spawns a Loading Page with a spinning wheel.

 

DavidDas__GISP_1-1690686267453.png

 

 

 

After waiting for a while, you get this error message:

 

DavidDas__GISP_2-1690686267454.png

 

 

So you attempt to Download the ZIP file a second time.

 

You get this new error message:

 

Not Found

 

DavidDas__GISP_3-1690686267456.png

 

 

How do you proceed?

 

I have found a way get around this issue which works most of the time.

 

You can manually assemble the necessary files by following the steps in the included PDF.

 

Best regards,

 

David Das

 

1 Solution

Accepted Solutions
MichaelLev
Occasional Contributor III

@MarcelŠíp Thanks a lot! I use Gavins's script many times every day (by cmd file) and it works fantastic.

View solution in original post

18 Replies
DavidDas__GISP
Occasional Contributor II

I did some more investigation on the issue of the Download failing with EXB 1.12.

In my previous post I presented a possible workaround on using EXB 1.12 with Node.js 14.21.3.

I looked at the ESRI documentation and found that Node.js version 16.20.1 is recommended.

 

https://developers.arcgis.com/experience-builder/guide/release-versions/

 

 

DavidDas__GISP_0-1690925776500.png

 

 

 

Downloaded Node.js version 16.20.1 (Gallium) from:

https://nodejs.org/en/download/releases

 

DavidDas__GISP_1-1690925776508.png

 

 

Selected Releases for Node.js 16.20.1 Gallium.

https://nodejs.org/download/release/v16.20.1/

DavidDas__GISP_2-1690925776513.png

 

 

Downloaded the file:

Node-v16.20.1-x64.msi

 

DavidDas__GISP_3-1690925776514.png

 

 

Installed Node.js 16.20.1

 

 

DavidDas__GISP_4-1690925776520.png

 

 

 

Ran a complete installation of the Node.js Server and Client processes and started Node.js.

Launched the Experience Builder Dev Edition 1.12 in Chrome.

 

https://localhost:3001

 

Attempted to download the ZIP file.

 

DavidDas__GISP_5-1690925776523.png

 

 

Kept refreshing the server\temp folder to monitor the files being written.

C:\DAVID\EXB\EXB13\server\temp\13\cdn\1

 

 

DavidDas__GISP_6-1690925776531.png

 

 

 

Kept refreshing this folder.

The themes folder was created.

Then the widgets folder was created.

C:\DAVID\EXB\EXB13\server\temp\13\cdn\1

 

DavidDas__GISP_7-1690925776542.png

 

 

 

Finally, the resources folder got created followed by the all-important config.json file.

Essentially, all the necessary files were written at this point.

The ZIP file should have been created and the process should have stopped.

C:\DAVID\EXB\EXB13\server\temp\13\cdn\1

 

DavidDas__GISP_8-1690925776546.png

 

However, the process hung.

I received this error message.

 

Not found

 

DavidDas__GISP_9-1690925776550.png

 

Most of the files and folders started to get deleted.

I was left with only these.

C:\DAVID\EXB\EXB13\server\temp\13\cdn\1

 

DavidDas__GISP_10-1690925776551.png

 

 

This means upgrading Node.js from 14.21.3 (Fermium) to Node.js 16.20.1 (Gallium) did not resolve the issue with downloading ZIP files.

 

The workaround is to monitor the server\temp folder and stop the process as soon as it finishes writing the widgets folder and manually assemble the missing files as I have explained in my previous post.

 

If someone has found a better solution, please share.

Best regards,

 

David

 

 

JeffreyThompson2
MVP Regular Contributor

I had not experienced this problem until today. Then, I realized I was not running my terminal in admin mode. When I restarted my server with my terminal in admin load. It downloaded without issue.

Attempting to download in regular mode produces the following terminal error:

JeffreyThompson2_0-1696951974184.png

 

GIS Developer
City of Arlington, Texas
DavidDas__GISP
Occasional Contributor II

 

Hi Jeffrey,

 

Thanks so much for sharing the issues you are having downloading the ZIP file in Experience Builder Developer Edition 1.12.

 

I upgraded to Windows 11 Enterprise, Version 22H2 and still getting similar error messages while running the download process.

 

We need to resolve this issue.

 

You are one of the most experienced developers in our Community.

Hoping you can help to figure out a reliable workaround.

 

0 Kudos
DavidDas__GISP
Occasional Contributor II

 

Hi Jeffrey,

 

I opened a Command Window as Administrator and started the npm server process.

 

DavidDas__GISP_0-1696957010993.png

 

 

 

 

When I attempted to download the ZIP File, I got this error message:

 

Not Found

 

DavidDas__GISP_1-1696957010995.png

 

 

 

DavidDas__GISP_2-1696957010997.png

 

 

The failed process left these temporary files:

 

C:\DAVID\EXB\EXB15\server\temp\7\cdn\1

 

DavidDas__GISP_3-1696957010998.png

 

 

I am using EXB Dev Edition 1.12

Node.js version 14.21.3

Windows 11 Enterprise, 22H2

 

I hope we can figure out a reliable way to download the ZIP file without having to manually assemble the required files and folders.

 

 

0 Kudos
JeffreyThompson2
MVP Regular Contributor

A few things to try:

  • Your Node version is out of date. The current version is 18.18.0. I know some people had issues using Experience Builder in Node 16, but they appear to be resolved in the 18 version.
  • Check your file structure to make sure that you do not have any folders without files in them. This can cause all sorts of odd webpack errors. Start checking at the folder in the error message.
  • The error indicates that there is something in a folder that should be empty. Maybe it could be resolved by copying your Experience? In the Experience Builder builder mode, try copying your Experience and then publishing and downloading without making any further edits.
GIS Developer
City of Arlington, Texas
0 Kudos
bdoventures
New Contributor III

For those who are concerned about having to "manually reassemble" files as noted in the PDF, I've found that if I end the process once the json is written, there's nothing missing for me.  The app works when uploaded for me at that point.

I have tried multiple potential solutions and not found a way to get the download process to correctly complete without errors using Dev Ed 1.13 on Windows 11, irrespective of Node.js version.

0 Kudos
LukasWürsch
New Contributor III

Hi, I had the same problem with ExB developers edition 1.13. I could not make it work properly on windows but running Experience builder on Ubuntu (in a virtual machine) worked for me.

0 Kudos
bdoventures
New Contributor III

Something that worked for me today in Windows 11 w/ EXB 1.13 and Node.JS 16.20.1:

After turning off almost all of my antivirus/firewall protection, I started the server in Windows Powershell rather than the normal command prompt.  Then, I was able to successfully download an app using Chrome.  Everything was properly zipped, and I didn't get any error messages - just deprecation warnings.

0 Kudos
MicahWilliamson
Occasional Contributor II

After 1.13 working without error for a number of days, I began to struggle with this today. I tried a fresh download (no custom widgets), new user, new appID, default APP, Admin cmd, PowerShell, cleared cache, reboot... all with the same result. I opened a case with Esri and got the typical non response. Then someone put me onto this thread.  I appreciate the PDF. Grabbing the compiled application during the spinning wheel seemed to be the only things that worked.  It took a few tries to get the timing down. but I am able to publish much needed updates now. 

It's a workaround, but .. Come on...