Near Me Widget crashes with multiple layers

650
10
12-06-2023 09:31 AM
KitKat94
New Contributor II

While building my application whenever I click the Near Me widget it crashes and gives me this error:

KitKat94_0-1701883594487.png

I do have about 20 layers in the near me widget. However, I was able to use these same layers (plus way more) in Web App Builder screening widget and it worked no problem.

Is there anything I can do? Or is there a better alternative to the screening widget? I want to allow a user to see what features are near a AOI of their choice.


Tags (4)
10 Replies
AzizaParveen1
Esri Contributor

Hi @KitKat94 

Is this happening during configuration or when you are using it after the app is launched? This is know issue and we are working on the fix for both at the configuration and runtime side, the fixes should be released in upcoming ArcGIS Online update in February.

James_Shreeve
New Contributor III

Good to hear that this is a known error and a fix will be available soon. I have exactly the same issue, I'm not able to even open the configuration window of the app my whole window just freezes. 

0 Kudos
KitKat94
New Contributor II

Both. It crashes during configuration, for example now I cant even delete the Near Me widget because the builder crashes when I click it. 

Then in the launched application it just gives me a spinning wheel for where the widget should be.

Thanks!

0 Kudos
AzizaParveen1
Esri Contributor

Will you be able to share your web map with us? It will be great if you can share the url here, so we can test the fix with your map.

Thanks so much.

Aziza

0 Kudos
KitKat94
New Contributor II

It is an internal application. Can I share with you individually?

0 Kudos
AzizaParveen1
Esri Contributor

I don't think I will be able to access it if the map is internal. I think it will be better if you could log a bug with esri tech support, they will be able to access your data and we will get access through them. When you log a bug, please mention my name and ask the analyst to directly contact me.

Thanks so much.

Aziza Parveen

0 Kudos
LondonWalker
New Contributor III

I am having this issue too. There also seems to be a limit with how many records are returned in the actual app.

0 Kudos
rwrenner_esri
Esri Contributor

I am also experiencing this issue and can confirm it has to do with the number of layers added into the widget rather than the number of records. The app goes unresponsive when configuring the Near Me widget once the 18th layer is added. 

I see a bug has been logged (BUG-000163939) and a fix is in the product plan. Until then, using fewer than 18 layers should prevent the issue from happening.

0 Kudos
LondonWalker
New Contributor III

I combined all my layers into one layer and it still doesn't work at least half the time if too many records are returned in the near me widget

0 Kudos