Issues with Filter, Query, and Print widgets after February 2024 Update

518
4
Jump to solution
03-01-2024 10:47 PM
Labels (1)
Jan_TPS
New Contributor

Hello, we currently have a number of public facing apps that use the below mentioned widgets. Prior to the Feb 2024 update, they are working fine. After the latest update, we noticed the following issues:

App link for reference: TPS Crime App YTD 

Issue 1) When selecting a value from the bottom of the Filter list, the list would randomly scroll back up

1.1) Using the app link > Filter tab > Neighbourhood dropdown > scroll down on the list and select any neighbourhood value > the list then goes back up

 

Issue 2) The filter doesn't show all values 

2.1) Using the app link > Filter tab > Turn off the Yesterday filter (to show all data YTD) > several values from the Location Type, Neighbourhood, and Division filters are missing. However, when you type a value in the search box, it would come up (eg using Neighbourhood > in the search box, type Yonge and the values would come up > make a selection and the values with Yonge will reset/disappear

 

Issue 3) Similar to 2 but occurring in Query widget 

3.1) Using the app link > Filter tab > Turn off the Yesterday filter (to show all data YTD) > go to Query tab > Neighbourhood values are also missing from dropdown (also applies to Division, Location Type)

 

Issue 4) Print widget showing an (X) in results 

4.1) Using the app link > Print tab > click Print > Results is marked with an X

 

Perhaps a lot to ask but we're wondering if it can be resolved sooner. We've been getting quite a number of inquiries from our users. Thank you!

@Jianxia 

0 Kudos
1 Solution

Accepted Solutions
Jianxia
Esri Regular Contributor

@Jan_TPS , Issue #2,3,4 are resolved. Could you please help confirm them? #1 is a known issue but a regression from this release. We will try to address it in June. The workaround is to toggle the filter button off before you make a selection from Neighbourhood dropdown. 

Jianxia_0-1709585293671.png

 

View solution in original post

4 Replies
Jianxia
Esri Regular Contributor

@Jan_TPS , thanks for the reproducible steps. I am able to reproduce the issues using the app you provided. We will address them asap and keep you posted.

Jianxia
Esri Regular Contributor

@Jan_TPS , Issue #2,3,4 are resolved. Could you please help confirm them? #1 is a known issue but a regression from this release. We will try to address it in June. The workaround is to toggle the filter button off before you make a selection from Neighbourhood dropdown. 

Jianxia_0-1709585293671.png

 

Jan_TPS
New Contributor

I can confirm that issues #2, #3, and #4 are now resolved. Thank you @Jianxia for the prompt response and action! Our team will be looking forward to the June release.

Jianxia
Esri Regular Contributor

Thank you for the confirmation, @Jan_TPS 

0 Kudos