Select to view content in your preferred language

Issues consistent adjustment of the Image widgets to mobile devices

600
3
Jump to solution
06-02-2023 04:02 PM
AndrewCastilloTBSL
Esri Contributor

Hi everyone,

 I recently created an app using Experience Builder and when I view it on mobile devices something is strange.

This is how it displays on my friend's iPhone XR

Screenshot 2023-06-02 163102.pngScreenshot 2023-06-02 163224.png

and this is how it looks in my Samsung Galaxy A10s

Screenshot 2023-06-02 163947.pngScreenshot 2023-06-02 165007.png

 

I also tested in another Samsung Galaxy A51 and it also shows the full images.

I don't understand this is happening because I set the position for all the image widgets to "Fit"

AndrewCastilloTBSL_1-1685746791893.png

Is there a setting I'm missing in Experience Builder to have the images in the image widgets fit all mobile devices? or is there a general issue with ArcGIS Experience Builder and IOS devices?

 

any help would be very appreciated.

1 Solution

Accepted Solutions
Richard_Purkis
Esri Contributor

Hi @AndrewCastilloTBSL @BethAnnWinebarger 

I believe you are both experiencing the known limitation also raised in this post: Responsive Experience not working on iOS.  As per the documentation, it is stated as a workaround for small and medium-screen device layout but in my experience it will also depend on the layout of the image as well.

There is a new Enhancement request logged to address this issue but it is a known limit from an external cause, which might not be changed anytime soon, unfortunately: 

  • ENH-000159330: Provide a method in Experience Builder to render images as expected on Large-screen iOS devices layouts

Hope this helps

View solution in original post

3 Replies
BethAnnWinebarger
New Contributor III

Here to agree with this issue of the image widget on mobile devices. I have only tested on IOS devices, but I feel like this is a fairly new bug (?) because I wasn't seeing this behavior on similar experience builders built last year. In addition to the 'Fit' setting not being respected, I have images not respecting the 'Fill' setting. 

Beth Ann
0 Kudos
Richard_Purkis
Esri Contributor

Hi @AndrewCastilloTBSL @BethAnnWinebarger 

I believe you are both experiencing the known limitation also raised in this post: Responsive Experience not working on iOS.  As per the documentation, it is stated as a workaround for small and medium-screen device layout but in my experience it will also depend on the layout of the image as well.

There is a new Enhancement request logged to address this issue but it is a known limit from an external cause, which might not be changed anytime soon, unfortunately: 

  • ENH-000159330: Provide a method in Experience Builder to render images as expected on Large-screen iOS devices layouts

Hope this helps

TonghuiMing
Esri Regular Contributor

The iOS limit of "Fill" has been resolved with the latest AGOL October release, so your cases with iPhone or iPad should work fine now. Let me know if you encounter any other issues. Thanks.

0 Kudos