Format integer to remove commas ExpBuilder

2219
9
02-01-2022 08:51 AM
Labels (1)
JayJohnsonWashoeCounty
Occasional Contributor III

Is it possible to control field formatting in either the Table widget or List widget in Experience Builder?  I have an integer field that I need to display WITHOUT the typical commas separating the thousands place.

What I want:   202109

What I'm getting:  202,109

 

Jay
Washoe County GIS
9 Replies
jcarlson
MVP Esteemed Contributor

I've noticed this too. Experience Builder seems to ignore the field formatting defined in the layer's visualization settings. Same with date fields, regardless of the formatting and whether you choose "show time" or not, it comes in as M/D/YYYY, HH:MM [AM/PM].

Would love to see field formatting settings at the data source level, to consistently control field display in all widgets.

- Josh Carlson
Kendall County GIS
RhettZufelt
MVP Frequent Contributor

Have not tested in the Table Widget, but in the List and Edit Widgets (all tied to the map), all you have to do is open the map in the good old Classic Map Viewer, config the popup for that layer, and un-check the "Use 1000 separator" box.

R_

JayJohnsonWashoeCounty
Occasional Contributor III

The data in question is just a table - no map.  So...no popup to configure...

Jay
Washoe County GIS
Ryan_Gould
New Contributor III

@JayJohnsonWashoeCounty 

I had the same issue. A thousands separator was displayed when numeric field values are used in labels, and pop-ups in ArcGIS Online or Enterprise.  This was a problem when displaying acquisition year for aerial photographs.

To resolve this in pop-ups: I used the Round function, with the number of decimal places set to 0.

Example:

"Round(($feature.ACQUISITION_YEAR),0)"

For List elements in ArcGIS Dashboards: I used the Text function, with "0" for the digit format. 

Example:

"return GroupBy(fs,[Text('EQUIP_NUM',0),'DATE','CAMP_NAME','ROAD_SEG','FUNCTIONAL_ROAD_CLASS'], "

I hope this helps.

0 Kudos
AdamBowen
New Contributor III

Still seems to be an issue. I can't do any sort of number formatting. I have percentages that show up in the Filter and Table widgets as integers (0.125 instead of 12.5%). This is a headache as I need it to filter as numeric values, but display in all contexts as a percentage. The only workaround that I am seeing is to convert it to a text and apply a percent sign after multiplying by 100. That's great for the table, but I can't filter the data as a range when it is text. Is the Experience Builder dead in the water or are they still developing this? It seems like a simple feature to overlook for over a year with no resolution.

Metropolitan_Planning_Council
New Contributor II

My workaround to this was to label the field with a % sign and use full integers as my percentage, and I did the same for the currency field. Until AGOL allows other number formats like percentages, currency, and dates this will be an issue.

0 Kudos
AaronKoelker
Occasional Contributor III

Having this issue as well, along with not being able to do a Search on Integer fields. Would like to be able to Search on a Facility ID field for example. The workaround of course is also to republish with the ID field changed to a text/string field, but that's not always an option depending on the data source.

-Aaron
0 Kudos
VenkataSrikanth_Dasari
Occasional Contributor
0 Kudos
VenkataSrikanth_Dasari
Occasional Contributor
0 Kudos