Filters in a Window

275
3
07-13-2021 12:54 PM
Labels (1)
JonathanMcDougall
Occasional Contributor III

So, I thought I was being smart, clearly failed again. :)

To save screen "real-estate" I thought it would be good to have a number of filters brought forward through a window. The screengrab below shows the result is correct as I apply a filter from the window, I've included the count which I used to verify it was working, however, as soon the window is deactivated (clicked off) it clears the filter.

Is there a setting, or something I'm missing to keep the filter(s) active after closing the window?

 

JonathanMcDougall_0-1626206077819.png

 

0 Kudos
3 Replies
ShengdiZhang
Esri Contributor

Hi Jonathan,

I can reproduce your issue and confirm that it is a bug. We will look into it.

Before this bug can be fixed, there is a work around that you can use the filter widget's icon arrangement style.

ShengdiZhang_0-1626228268564.png

 

Thanks for your reporting.

 

Regards,

Shengdi

0 Kudos
JonathanMcDougall
Occasional Contributor III

@ShengdiZhang 

Hi, thanks for the response.

Have tried your suggestion, however, same result with the filter "switching off" as soon as I close the window. All filters remain active, using the other arrangements too, right to the point of clicking off window.

Looking forward  to the bug-fix.

0 Kudos
ShengdiZhang
Esri Contributor

Sorry I didn't make it clear in my last reply. What I mean is that you can put the icon filter widget on the page, but not on the window.

As for the window issue, after discussion it is not an easy bug to fix (or more like an enhancement), and I'm afraid it cannot be solved in the next release.

Regards,

Shengdi

0 Kudos