Feature Info widget - Selected Features loses pop-up style

1030
10
Jump to solution
04-26-2021 10:45 AM
Labels (1)
JayJohnsonWashoeCounty
Regular Contributor

When I change a Feature Info widget from a data layer to "Selected Features", the widget loses the pop-up styling.  In the screen shot below, the left Feature Info widget is pointing to a data layer in the map and shows a nice format as defined in the map layer's pop-up, while the right Feature Info widget is pointing to Selected Features and has lost the pop-up formatting.  

JayJohnsonWashoeCounty_0-1619458959252.png

Is this intentional?  

What I'm trying to do is show ONLY the Feature Info for the selected feature on the map.

Jay
Washoe County GIS
2 Solutions

Accepted Solutions
BrittanyBurson
Occasional Contributor III

Thank you both for posting this. I am having the same issue, where I want to only show the 1 record in the Feature Info window. However even when I choose "Respect the source" it ignores my pop-up formatting.

View solution in original post

Jianxia
Esri Regular Contributor

This is a known issue. We are looking into it.

View solution in original post

10 Replies
RyanBohan
Occasional Contributor III

Hi Jay,

I am having the same issue.  I am trying to configure the "Feature Info" widget for mobile screens.  If I leave the Source as Default the pop-up looks great.  If I change it to "Selected features" it seems to ignore the "Respect the source"  

Since it is on mobile I want the user to be easily able to see the feature they selected, not having to arrow through all the pop-ups (there could be thousands).

Screen shots attached to help with debugging.

RyanBohan_0-1619540667191.png

RyanBohan_1-1619540676302.png

BrittanyBurson
Occasional Contributor III

Thank you both for posting this. I am having the same issue, where I want to only show the 1 record in the Feature Info window. However even when I choose "Respect the source" it ignores my pop-up formatting.

Jianxia
Esri Regular Contributor

This is a known issue. We are looking into it.

TanGnar
Occasional Contributor

Would really love to see this fixed soon! Thanks!

0 Kudos
Jianxia
Esri Regular Contributor

Sorry, my previous reply is inaccurate so I removed it. Looks like for this popup issue, we are still on the track to fix it in the upcoming update. 

AnthonyJones5
Occasional Contributor

Hi Jianxia,

I've recently come across a similar issue. I have a layer with arcade and html configurations in the pop up. As of yesterday everything was working fine but now the Feature Info pane in EB is not respecting the styling of my pop up. I've noticed that the drop down in the style section where you can select "Custom" or "Respect the source" has disappeared. Bizarrely if I change the feature info data source to the same layer but in a back up web map I made yesterday, then the option for "Respect the source" becomes available again.

Has something likely corrupted in my map or is this a known bug? In further testing I did try to create a new experience with the same map and layer and came across the same problem so it seems like EB just no longer likes my map. It's like it doesn't recognise that the layers in the map have a custom pop up.

Any help would be much appreciated.

Kind Regards

Anthony

0 Kudos
AnthonyJones5
Occasional Contributor

Hi Jianxia,

I've done some further testing and I think I've isolated the problem to the content of the pop up. My pop up includes arcade pop up elements and yesterday I had one text pop up element too. It seems that once I removed the text pop up element then the feature info panel in EB didn't recognise that the layer had a custom pop up. Is this a problem with EB recognising the new Arcade pop up elements?

Thanks

Anthony

0 Kudos
Jianxia
Esri Regular Contributor

@AnthonyJones5 , Could you provide a reproducible sample?

0 Kudos
AnthonyJones5
Occasional Contributor

Hi Jianxia,

I've created a dummy experience and shared it to you in a group. You can access the builder here

I've been able to replicate the issue in this test. In the first image below you can see how the custom drop down is available as the pop up contains a text element. But in the second image, with the text removed from the pop up, the drop down is no longer available. 

Let me know if you need anything else.

Kind Regards

Anthony

AnthonyJones5_4-1650459191590.png

AnthonyJones5_5-1650459265495.png

 

 

0 Kudos