Feature Info widget - Selected Features loses pop-up style

526
5
Jump to solution
04-26-2021 10:45 AM
JayJohnsonWashoeCounty
Regular Contributor

When I change a Feature Info widget from a data layer to "Selected Features", the widget loses the pop-up styling.  In the screen shot below, the left Feature Info widget is pointing to a data layer in the map and shows a nice format as defined in the map layer's pop-up, while the right Feature Info widget is pointing to Selected Features and has lost the pop-up formatting.  

JayJohnsonWashoeCounty_0-1619458959252.png

Is this intentional?  

What I'm trying to do is show ONLY the Feature Info for the selected feature on the map.

Jay
Washoe County GIS
2 Solutions

Accepted Solutions
BrittanyBurson
Occasional Contributor III

Thank you both for posting this. I am having the same issue, where I want to only show the 1 record in the Feature Info window. However even when I choose "Respect the source" it ignores my pop-up formatting.

View solution in original post

Jianxia
Esri Regular Contributor

This is a known issue. We are looking into it.

View solution in original post

5 Replies
RyanBohan
Occasional Contributor

Hi Jay,

I am having the same issue.  I am trying to configure the "Feature Info" widget for mobile screens.  If I leave the Source as Default the pop-up looks great.  If I change it to "Selected features" it seems to ignore the "Respect the source"  

Since it is on mobile I want the user to be easily able to see the feature they selected, not having to arrow through all the pop-ups (there could be thousands).

Screen shots attached to help with debugging.

RyanBohan_0-1619540667191.png

RyanBohan_1-1619540676302.png

BrittanyBurson
Occasional Contributor III

Thank you both for posting this. I am having the same issue, where I want to only show the 1 record in the Feature Info window. However even when I choose "Respect the source" it ignores my pop-up formatting.

View solution in original post

Jianxia
Esri Regular Contributor

This is a known issue. We are looking into it.

View solution in original post

TanGnar
New Contributor III

Would really love to see this fixed soon! Thanks!

0 Kudos
Jianxia
Esri Regular Contributor

Sorry, my previous reply is inaccurate so I removed it. Looks like for this popup issue, we are still on the track to fix it in the upcoming update.