Experience Builder Table Widget - Change Field Names

Jump to solution
05-21-2021 01:31 PM
New Contributor II

Happy Friday,

I am using the Table Widget in Experience Builder.  When configuring fields in the Widget, I can select fields for initial display to reduce the number of fields needed.  The problem is that the widget is defaulting to the Field name in the table. 

Note: This is a stand alone table that is in a map service published from our ArcGIS server and has been loaded into a Web Map.  The table is not a hosted feature layer nor has it been added as an item in ArcGISOnline (beyond being in a webmap).  For the widget, I am choosing the table from the WebMap when choosing data from the widget.  I am not choosing the table directly from the map service.

Since there doesn't appear to be a way to alter the field names in the widget, I tried changing the field name in the web map to display as I want them (ie. configure the attributes in the popup).  But the field names still show as the original in the Table in Experience.

Am I wrong in thinking that since I added the table to the widget from the WebMap data source that the field names should use what I configured in the Web Map?  

Or am I going to have to go back to Pro and set the aliases on the layer in the project and republish?

For reasons of simplification, I was hoping not to have to add the table as an item in ArcGIS Online and change aliases there.




1 Solution

Accepted Solutions
Esri Contributor

Hi all, thanks for the feedback! The table widget currently does not honor web map settings. Field names are stick to aliases on the layer. But the widget, in the near future, will allow you to choose from two modes: honor pop-up settings/customize field names. Hope it helps!

View solution in original post

14 Replies
Occasional Contributor III

I have run into this, and I agree, I would think that the widget would inherit the alias if you have it selected through the Web Map.  I'd love to hear as I have several I'd like to be able to customize the Alias for...

Occasional Contributor

The inability to clean up the Table widget is frustrating, both in terms of using field aliases as header names and making adjustments to the field configurations themselves. 


I would have thought the table would honor the pop-up attribute configurations when selecting a layer in a web map as the source, or at least would have the option to honor those settings. For example, in the picture below, the time portion of the timestamp and the comma in year would be great to get rid of in the table without having to revamp fields and republish... Especially when they are removed in the pop-up settings for the layer...



by Anonymous User
Not applicable

I ran into the comma issue you highlighted when I want to show install year for data. I went through the process to remove the comma (one thousand separator) through this link: https://support.esri.com/en/technical-article/000024156. This removed the comma in the web map and also shows the comma removed in a web app through Web AppBuilder. When I create a project in Experience Builder the comma is gone in the pop up windows, but when opening the data tables the comma is back. I'm hoping someone has been able to figure how to get that comma out of the table in experience builder.

0 Kudos
New Contributor II

I ran into this issue with making a chart in Experience Builder. I am using Census data sourced from Living Atlas in a Web Map. The aliases are included in layers, but are not being used in the chart. I'm still thinking of another way around this issue.

Occasional Contributor III

Hi @ctalleygreenville and others, I am here with same issue. I agree the expected behavior to me is that field names in the Table widget should inherit the aliases set in the web map, but this is not happening.

Configuration in the map:


Table widget reflection:


Of course this example just shows an added space, but the idea is there.

Has anyone confirmed if aliasing at the layer level will populate into the Table widget fields? I want to try, but we are using a collaboration layer, and adjusting the schema always causes our Experience/map to break. Would be helpful to confirm/deny beforehand.

Tagging @TianWen from ExB team.

Thank you

Occasional Contributor III

Update: changing the aliasing on the layer fields did update the Table field names. Note that I had to remove and re-add the table to see the change.



0 Kudos
Occasional Contributor II

Hi, could you please explain how you did this?

0 Kudos
Occasional Contributor III

Hi @Hayley 

What I did was change the field name at the layer level, since it doesn't appear to honor the field name alias changes through the pop-up editor in the Map.

If you go into the Data tab for your hosted feature layer, then choose Fields:


You can then click on each field name to change the "Display Name"/alias


There was an update to Experience Builder in September so I'm not sure if the map settings are now honored, or if you can configure it within the widget itself now.

Hope this helps!


Occasional Contributor II

Yay that worked perfectly, thanks so much!