Select to view content in your preferred language

Experience Builder Slow Map Layers Widget

6575
28
09-15-2021 08:29 AM
Labels (2)
HeatherBell
Occasional Contributor

We've been building a web app in experience builder. The first page is a map with a sidebar with the map layers widget. When previewing the app, the map loads okay (5-10 seconds), but the map layers widget can take up to a minute to load. I've tried to optimise it by switching off all the layers, and saving the web map using the new map viewer. However, it hasn't sped up the load time. Has anyone found a way to speed up the load time? There are approximately 100 layers in the map but they are all switched off. See the attached image. Thank you, Heather. 

GIS Analyst @ The Rivers Trust
28 Replies
Stefan_Thorn
Occasional Contributor II

Hello Heather,

I am also having the same experiences. I have created first a webmap in the new map viewer and using this webmap to build up in EB. in the map viewer the performance is normal. The performance for popups is also dramatically slow. 

HeatherBell
Occasional Contributor

Hi Stefan, 

I have raised a case with Esri's technical team who are assiging a subject matter expert. I haven't heard back yet but I will post any solution if there is one on here. 

 

Best wishes,

Heather

GIS Analyst @ The Rivers Trust
Stefan_Thorn
Occasional Contributor II

Hello Heather,

Hopefully, they will fix it, otherwise EB is a lose canon. I wondering if you also experiences a slow response with the popups in the map. I think, both are related with each other.

Popup has very slow response in EB compare to new ... - Esri Community

Greets,

Stefan

KristianTuusjärvi
New Contributor II

I'm struggling with this issue as well.

RobMacDonald1
New Contributor

Hi All

Was this ever solved / responded to?

Thanks 🙂

TimConfare2
Occasional Contributor

I am also wondering the same.  The fact that EB is even slower than WAB and has barely half the widgets make EB useless to us as a web app.  I hope someone has some answers

TonghuiMing
Esri Regular Contributor

Is this issue still happening? If so, does anyone care to share a sample app?

0 Kudos
JustinH
New Contributor III

Hello- 

 

This still seems to be an issue in EB. My map has less than 50 layers and it takes forever to load. Maybe it is an internet issue but the layer widget takes forever to load. I am talking 10-20 minutes. 

 

Thanks for your help. 

0 Kudos
HeatherBell
Occasional Contributor

Hi, here is a link to our Experience Builder App: https://experience.arcgis.com/experience/9163ff6bdb0f4b34bba59f1a92d9a20f

It is faster than it used to be, by removing some problems layers identified using the Developer Tools in Google Browser, but I would say it is still a bit slow to load.

 

Thank you, 

Heather.

GIS Analyst @ The Rivers Trust