Experience Builder Edit Widget Not Functioning Correctly

2362
21
04-27-2022 03:34 PM
KaraUtter
Occasional Contributor III

After adding my editable layers, they aren't showing up properly in the Edit widget. None of them are present but there is a strange one showing up, please see image below.

KaraUtter_0-1651098799022.png

 

0 Kudos
21 Replies
KaraUtter
Occasional Contributor III

Now I see that when I turn on my layers, they do appear in the new feature portion of the edit widget, however that weird "jimu-draw-measurements-layer-widget......." is from the draw tool. Why does that have to be there and if it has to be there, why can't I rename it to something that makes sense?

0 Kudos
KaraUtter
Occasional Contributor III

None of this will make sense to anyone and I am forced to have it up there because I Have both the edit and draw widgets connected to the map. It makes no sense but I can't see how to get rid of it?

KaraUtter_0-1651159439004.png

 

0 Kudos
TonghuiMing
Esri Regular Contributor

Hi @KaraUtter - for the extra layer from the Draw widget, we will take a look and fix it in the next upcoming release. Sorry for the inconvenience. (Further details in https://community.esri.com/t5/arcgis-experience-builder-questions/draw-layer-displays-in-edit-widget... )

0 Kudos
KaraUtter
Occasional Contributor III

Thanks, Tonghui. Do you know the date of the new release?

0 Kudos
TonghuiMing
Esri Regular Contributor

The Q2 release should happen sometime around late June or early July according to previous practice.

0 Kudos
KaraUtter
Occasional Contributor III

Bummer! The department I am building this app for is going to be confused by this. They aren't as savvy with anything on a computer so this is just going to get in the way for them, unfortunately.

0 Kudos
TonghuiMing
Esri Regular Contributor

This issue should be resolved with AGOL 10.2 release today.

0 Kudos
KaraUtter
Occasional Contributor III

Well, the issue above was resolve and replaced by a new issue. As soon as I add my first editable layer that I want connected to the edit widget, it adds a bunch of other layers that are not editable and says, "highlight" next to them???

KaraUtter_0-1656100647602.png

 

0 Kudos
TianWen
Esri Contributor

It looks like a data-specific problem. I think it would be helpful if you can provide sample data. 🙂

0 Kudos