Embedded Insights iFrame asking for Sign In

323
2
Jump to solution
06-07-2021 01:33 AM
Labels (1)
JonathanMcDougall
Occasional Contributor III

Hi,

I've created a number of Insight pages to embed into an Experience Builder page, all works well but Insights is asking for a Sign In.

My data is hosted on AGOL and all shared Publicly, when sharing the Insights page it's shared to everyone too. I want to be able to share the Experience as it is framed around our Climate and Nature Emergency Strategy, however, having metrics etc asking for logins doesn't go down well for a public user experience.

The Insight I created has multiple pages, each one is shared and then embedded into the right area of the ExpB.

Is there anything I'm missing? 

The iFrame is not complicated;


<iframe src="https://insights.arcgis.com/#/embed/556353c890994d5e830b138d4cb08b9b" width="700" height="170" frameborder="0"></iframe>

This is the site still under construction;

https://experience.arcgis.com/experience/54b1b847e0324cec9670d30e2f0cbffc/

Do I have to recreate everything in Insights online rather than Desktop?

0 Kudos
1 Solution

Accepted Solutions
TonghuiMing
Esri Contributor

Hi @JonathanMcDougall - when I open the standalone Insights link you shared directly, it prompts me to sign in as well:

InsightandEmbed.png

I assume the problem you've encountered has something to do with this Insight app's privilege setting. It might be a direction to double-check on.

View solution in original post

2 Replies
TonghuiMing
Esri Contributor

Hi @JonathanMcDougall - when I open the standalone Insights link you shared directly, it prompts me to sign in as well:

InsightandEmbed.png

I assume the problem you've encountered has something to do with this Insight app's privilege setting. It might be a direction to double-check on.

JonathanMcDougall
Occasional Contributor III

@TonghuiMing 

Hi, thanks for the reply.

I'm not sure whether it's me or Insights that's flakey. I ended up creating a brand new Insight using the same data, the same workbook structure, same publication and sharing options on the data and workbook. This time 'round everything is ok and I've got it embedded publicly. 

I do have another issue with Insights which I've sent to ESRI support , "Something is wrong" I see all too often.