Embed Widget Changes & Stuck Reloading Survey123

423
3
05-19-2021 10:50 AM
Kevin_Thompson
New Contributor III

 

Hello All,

With the new version of Experience Builder that was just released a few weeks ago, there seems to be changes that were made to the embed widget? Going through the documentation I cannot seems to find the exact changes in detail as it seems some functionality has been removed.

https://doc.arcgis.com/en/experience-builder/get-started/whats-new.htm

In my application I have Survey123 embedded and this is linked to the data in the map. Previously I could set what the window would look like without a record selected and it would not load. Now it opens Survey123 automatically and since I don't have a record selected it just permanently tries to load and shows up with the GlobalID error as it should as nothing is selected.

For my users this was not as elegant as before and I have had to ensure this a training thing. Is there a way I can still do this in the new version or maybe have a window overtop when no record is selected to cover it?

I have spent hours playing around trying to find how/if this is even possible after the changes and I can't find a solution.

KevinThompson1_0-1621446120057.png

 

Kind Regards,

Kevin T

Tags (1)
0 Kudos
3 Replies
TonghuiMing
Esri Contributor

Hi @Kevin_Thompson - is it possible to share the app with me so I can take a look? It would be helpful if more information about how the app is configured being provided. 

Kevin_Thompson
New Contributor III

I added you to our ESRI Support Group, let me know if you can see it now

0 Kudos
TonghuiMing
Esri Contributor

Hi Kevin,

We had two issues fixed in the recent AGOL June update - see Experience Builder- Embed Widget Issue with Survey123 and Embed widget problems after april AGOL update.

 

Let me know if your issue has been resolved or you still see the same behavior.

 

Best,

Tonghui

0 Kudos