Chart value labels disappear after selecting and clearing data filter via Map Actions

356
1
02-28-2023 09:21 AM
PorterR
New Contributor

I am building a dashboard in Experience Builder. On there site there is one map with polygons and three charts connected via Map Actions. The charts have value labels turned on and VISIBLE when no data is selected. 

The user can select a polygon by clicking on the map. The three charts filter to display data from that District only. Value labels still VISIBLE in the charts. 

However, when the user clears the selection by closing the pop-up, the value labels DISSAPEAR. 

I have tried recreating the charts. Formatting them differently. Running the dashboard from a different browser. Nothing seems to address this bug. Any solutions or suggestions would be greatly appreciated. 

0 Kudos
1 Reply
WeiYing1
Esri Contributor

Hi @PorterR ,

Thanks for your feedback! But I failed to repro the issue based on my understanding of your configuration. 
Could you provide more details?

The charts have value labels turned on and VISIBLE when no data is selected. 

The user can select a polygon by clicking on the map. The three charts filter to display data from that District only. Value labels still VISIBLE in the charts. 


1. When configuring the chart did you use Default data view or Selected feature? 
2. Did your chart use a different layer input with the map trigger layer? (But filter action set between the two layers?)
3. Which chart type did you use? 
4. Based on my understanding, you are expecting to not see the value label in chart when there is no data selection, right? 

0 Kudos