WebGISDR import/restore of full site fails at ArcGIS Datastore

01-08-2021 08:50 AM
New Contributor III

I am attempting to migrate an existing ArcGIS Enterprise - single server base deployment to a new machine. Trying to use the webgisdr utility to minimize downtime, following steps outline in this blog post

When restoring/importing the full webgisdr backup file from original installation to the new server (after the completing the base installation and setup) I run into an error and the restore fails for ArcGIS Datastore. Please see the attached screenshots. It looks like the process is attempting to register a tile cache datastore (not sure why - there should be one already configured).

If I drop the tileCache store from the original deployment, export the backup file and restore it to the new server, the import process is successful (relational datastore, portal and server).

We have multiple environments and I tried the full restore on two similar environments and ran into this issue on development environment. System Test environment restored successfully with both the relational and tileCache datastores. The only difference is the development environment has ArcGIS Insights which is documented to cause issues and I uninstalled ArcGIS Insights and removed the registered relational datastore types prior to starting this process.

Would appreciate assistance figuring out this issue. @JonathanQuinn 

1 Reply
Occasional Contributor III

Hi, the easiest way to do this if the new machine is on the same network / can talk to the existing machine is to set up HA, fail over then remove the old machine. The process is described here

Migrate to new machines—Portal for ArcGIS | Documentation for ArcGIS Enterprise

I've done this a few times now and find it easier than trying to use webgisdr. I make sure machines are patched to the same level before hand though.