Unable to access Living Atlas Subscriber content from portal

1151
5
08-21-2019 01:30 AM
Chaitanya_Ganjam
New Contributor II

I am unable to enable Living Atlas Subscriber content in ArcGIS Portal ( portal 10.6.1 single box installation). When I try to enable the content at Portal-->Organization --> ArcGIS Online-->Subscriber

getting the error that "The credentials you have provided are not valid or cannot be used with ArcGIS Online Living Atlas content configuration you have specified" . When I verify the developer tools response, found that i am unable to access https://XXX.domain.com/portal/portaladmin/system/content/livingatlas/validate URL and getting "UNABLE_TO_VALIDATE_ONLINE_ORG_USER , java.net.ConnectException: Connection timed out: connect" error.

I am able to access ArcGIS online with the same credentials and able to access subscriber content on ArcGIS Online.

0 Kudos
5 Replies
jill_es
Esri Contributor

A couple of questions to help isolate the possible issue:

  1. Are you signing in to ArcGIS Online using built-in or enterprise logins?  The ArcGIS Online account you're using will need to be a built-in account.
  2. Does your ArcGIS Enterprise portal have access to the internet?  This is necessary to go through this workflow; this is elaborated on further in our documentation.
Chaitanya_Ganjam
New Contributor II

Hi Jill, Thank you very much for your response. I am using ArcGIS online  built user and the portal server has internet access. I am able to login into my ArcGIS online page with same credentials on portal machine. If I verify the below URl to https://webadaptorhost.domain.com/webadaptorname/sharing/rest/portals/checkUrl i am getting below error.

{   "success": false,   "error": {"message": "Unable to connect, connection timed out"} }

Any clue and help is much appreciated.

0 Kudos
jill_es
Esri Contributor

Thank you for that additional information.  With this in mind, I recommend creating a case with Technical Support; doing so would allow for somebody to look into the issue further and get the proper resources looped in.

0 Kudos
Chaitanya_Ganjam
New Contributor II

I have resolved the problem by adding correct proxy settings at  https://XXX.domain.com/webadaptorname/portaladmin/system/properties. The proper settings are 

{"httpProxyHost":"Proxyserver.domain.com",

"httpsProxyHost":"Proxyserver.domain.com",

"httpProxyPort":ProxyserverPort(eg 8090),

"httpsProxyPort":8090

"nonProxyHosts":"portalname.domain.com"} .

All required was to find correct "Proxyserver.domain.com" and it is necessary to mention nonProxyHosts value.

jill_es
Esri Contributor

Excellent, glad to hear that everything is working!

0 Kudos