The server is not ready for publishing

2367
7
06-05-2017 06:24 AM
chengchao
New Contributor

When I publish the webservice through Arc MAP 10.4.1 , the final stage of releasing service appeare 'the server is not ready for publishing.'

The sample service of Arc Server 10.4.1 can be access. Restarting the Arc Server service, it still doesn't work.
The Arc Server is authorized and was installed in the c drive of computer.
Does the Arc Server 10.4.1 need to reinstall or to patch???

Tags (1)
0 Kudos
7 Replies
RebeccaStrauch__GISP
MVP Esteemed Contributor

Yes, there is a patch.  I would start with ArcGIS Server 10.4.1 Publishing Patch 2  to see if that fixes your issue.

ArcGIS Server 10.4.1 Publishing Patch 2   (blog)

If not, make sure to analyze you services and make sure there are not any errors that need fixing first.

JonathanQuinn
Esri Frequent Contributor

If it still doesn't work after installing the patch, run Fiddler while publishing and you should see requests to the Publishing Tools service.  Check the response for those requests and make sure that there are no errors returned.  You may just want to step through all other requests and make sure no requests are failing.  I'd say there's one or more that aren't going through for whatever reason, but ArcMap returns that generic error message.

0 Kudos
shan_sarkar
Regular Contributor

Cheng,

Please check the status of the Publishing tool from the server manager. If the tool is stopped, starting, or stopping you would need to change the tool status to Started before you go back to publishing the service.

~Shan


~Shan
jorisfrenkel
Occasional Contributor II

I have this error quite often. I just need to close and restart ArcMap, reload the MXD and then publishing works fine.

Joris

AndresCastillo
MVP Regular Contributor
vipulsoni
Occasional Contributor

We faced similar issue, then restarted the publishing tools and publishing tools ex map service and then tried publishing but it didn't work. after that restarted the arc map and then the publishing work smoothly.

ArcMap 10.8 and ArcGIS Server 10.8.1.

AndresCastillo
MVP Regular Contributor

Thank you for your input @vipulsoni 

This is also documented in the Esri technical support article I reference above:

https://support.esri.com/en/technical-article/000012610

Error: The server is not ready for publishing. Please check if the Publishing Tools on the server are started

"Restart ArcMap and republish the MXD.

In some instances for this recurring issue, restart ArcMap, load the MXD, and republish the service."