The Import XML Workspace Document tool with my enterprise goedatabase.

3478
1
11-04-2015 11:45 AM
PaulHuffman
Occasional Contributor III

I have been trying to import a xml file made with export xml workspace document from a 9.3 enterprise geodatabase, SQL server,  to a 10.3.1 enterprise geodatabase, SQL server.  Trying the whole geodatabase, importing to a new empty geodatabase, I got "999999 : Error executing function" and "The application is not licensed to create or modify schema for this type of data." and "The operation was attempted on an empty geometry" and "Failed to execute (ImportXMLWorkspaceDocument)."   I then tried a smaller piece of the old geodatabase, just a single feature dataset.  Tried importing to a different non empty geodatabase.  Tried remaking the xml file from the old geodatabase.  Always get the same error messages. 

Tags (1)
0 Kudos
1 Reply
DerekLaw
Esri Community Moderator

Hi Paul,

The internal schema tables of the geodatabase were significantly changed at the ArcGIS 10.0 release from previous releases. Learn more here: What's new for geodatabases in ArcGIS 10

I suspect the workflow you are trying to perform: export XML schema from a 9.3 geodatabase, then import the XML schema into a 10.3.1 geodatabase is NOT supported.

I suggest you try to upgrade the 9.3 geodatabase to 10.0 first, then export the XML workspace document.

Hope this helps,