Stage Utility Network

406
2
08-13-2021 07:04 AM
James_Armstrong
Occasional Contributor

I am in a testing and learning mode with the Utility Network. Though there have been many bumps in the road, I continue to make (albeit slow) progress.  Right now I am having issues with the Stage Utility Network tool.  While this tool successfully ran in the FGDB environment, errors happen when using this tool on the exact same database, though in an enterprise environment.  The first error was resolved by changing the database connection from the SDE user to a superuser (using postgres).  The current error being encountered is as follows.  The service area FC being used is located inside the dataset, but the same thing happens if the service area FC is located outside the dataset.  Suggestions?

James_Armstrong_0-1628863188032.png

Also, I have been looking at videos and youtubes and written documents to understand the UN better.  Any thoughts, ideas, or suggestions on good best practice info on UN would be greatly appreciated.

James

0 Kudos
2 Replies
PaulLeBlanc1
Esri Contributor

You can't use the superuser (ie postgres) when creating the utility network. https://pro.arcgis.com/en/pro-app/latest/help/data/utility-network/create-a-utility-network.htm

You'll need to create a new user, make your connection (SDE file) with that user, and pass that as input to Stage Utility Network.

 

I see that your service territory is already inside your enterprise geodatabase (and owned by the SDE schema). I'd recommend deleting that feature class.

I'll also investigate that error message from import xml -- what version of Pro are you using?

0 Kudos
James_Armstrong
Occasional Contributor

Hey Paul,

Thanks for the response.

  • Working in the database is not my strongest suit, but I do understand what your saying.  I will work on creating a database user for this purpose.
  • I will also delete the service area from within the dataset, keeping the service area FC that is outside the dataset.
  • Finally,  I am using version 2.8.  Through an earlier issue, I worked with ESRI tech support and we discovered that the UN tools will not load at version 2.8.1.

I will follow up on this thread after accomplishing the first two bullets above.

James

Here is a follow-up:

  • I was able (I think) to create a new database user (un_dbo) with the correct privileges.  Once this new schema was created I copied the data from the sde into it (the un_dbo schema). Should the owner of the database be the same as the new user/schema?
  • When I ran the stage utility network tool again, it seems to go further, but ends with the following error as shown in attached pics.    The error indicates that my geodatabase is not updated.  When looking into this more, I do not see that it needs to be updated.

 

I'm sure it is something I have done incorrectly.  I admit that I am a bit over my head in working with the Postsql and database.  Any help, suggestion, or advice you can offer will be greatly appreciated.

 

James

 

0 Kudos