Since I installed a sll certificate on my IIS I cannot log into arcgis manager

614
1
01-26-2017 03:39 AM
RobertBuckley1
Occasional Contributor

Since I activated SSL on IIS i can´t log into arcgis server manager and access to my wms services have been lost from outside my network.

Could anyone advise me on how to set up this again?

0 Kudos
1 Reply
RandallWilliams
Esri Regular Contributor

Hi Robert, I see this and a similar question that was asked previously.

What preceded this issue? Did you attempt to import a CA signed certificate and then experienced failures?

In the near term, if you're unable to access server manager over either HTTP or HTTPS protocols, we can get you back in by reverting to the default self signed certificate.

1. Stop ArcGIS Server

2. Drill down to \\Program Files\ArcGIS\Server\framework\runtime\tomcat\conf\server.xml. Open this file with a text editor and scroll down to the bottom.

3. Change the value of the keyAlias to keyAlias="SelfSignedCertificate"

like

<Connector SSLEnabled="true" ciphers="TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384, TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384, TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA, TLS_DHE_RSA_WITH_AES_256_GCM_SHA384, TLS_DHE_RSA_WITH_AES_256_CBC_SHA256, TLS_DHE_RSA_WITH_AES_256_CBC_SHA, TLS_RSA_WITH_AES_256_GCM_SHA384, TLS_RSA_WITH_AES_256_CBC_SHA256, TLS_RSA_WITH_AES_256_CBC_SHA, TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256, TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256, TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA, TLS_DHE_RSA_WITH_AES_128_GCM_SHA256, TLS_DHE_RSA_WITH_AES_128_CBC_SHA256, TLS_DHE_RSA_WITH_AES_128_CBC_SHA, TLS_RSA_WITH_AES_128_GCM_SHA256, TLS_RSA_WITH_AES_128_CBC_SHA256, TLS_RSA_WITH_AES_128_CBC_SHA" clientAuth="false" connectionTimeout="20000" connectionUploadTimeout="10000000" disableUploadTimeout="false" keyAlias="SelfSignedCertificate" keystoreFile="C:\Program Files\ArcGIS\Server\framework\etc\certificates\arcgis.keystore" keystorePass="not.the.password" maxHttpHeaderSize="65535" maxPostSize="10485760" maxThreads="150" port="6443" protocol="org.apache.coyote.http11.Http11Protocol" scheme="https" secure="true" server=" " sslEnabledProtocols="TLSv1.2,TLSv1.1,TLSv1" sslProtocol="TLS" useServerCipherSuitesOrder="true"/>
 

4. Start the GIS Server again.

0 Kudos