Registering versioned data

4551
10
Jump to solution
07-16-2015 06:07 PM
AmyKlug
Occasional Contributor III

Just upgraded to 10.3 and unable to publish versioned data even though the database is registered with the server. I just get the message "Feature Service requires a registered database". With 10.2 I was able to right click on the analyze error and register the version but now I get an error that the database has already been registered.

0 Kudos
1 Solution

Accepted Solutions
BrianOevermann
Occasional Contributor III

Amy,

Create a connection to your database specifically for your transactional version. If you use Direct Connects, use the ArcToolbox tool: "Create Database Connection" (in the Data Management-->Workspace toolbox), otherwise use "Create ArcSDE Connection File" (same location) if using the ArcSDE Service. The important step with either is to specify the version to be used. With "Create Database Connection" you need to expand the Geodatabase Connection Properties section to get at the version drop-down.

Once you have that connection, register it with Server. Connect to your data with the new connection and add your versioned data to your .mxd. If you have other data as part of this same service, add it by using a connection to the default database. For Feature Services with versioned data, I tend to not have extraneous data added alongside the versioned data in the same map service. But that's just the way I do things and I don't know if that's a "best practice" or not.

View solution in original post

10 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Amy,

Check to make sure that you are connected to the database as the same user you used to register the database with ArcGIS Server.

For example, if I registered the database as 'user1', but then I connect as 'user2' to publish the data, I will receive an error that the database is not registered.

0 Kudos
AsrujitSengupta
Regular Contributor III

Also make sure that you are connected to the same Transactional Version while publishing, that was used to register the database initially.

AmyKlug
Occasional Contributor III

I added the default layer using the database connection I am publishing with then created the version directly from the default version.

I don't get that error when I switch to the default version and try and publish

0 Kudos
BrianOevermann
Occasional Contributor III

Amy,

Create a connection to your database specifically for your transactional version. If you use Direct Connects, use the ArcToolbox tool: "Create Database Connection" (in the Data Management-->Workspace toolbox), otherwise use "Create ArcSDE Connection File" (same location) if using the ArcSDE Service. The important step with either is to specify the version to be used. With "Create Database Connection" you need to expand the Geodatabase Connection Properties section to get at the version drop-down.

Once you have that connection, register it with Server. Connect to your data with the new connection and add your versioned data to your .mxd. If you have other data as part of this same service, add it by using a connection to the default database. For Feature Services with versioned data, I tend to not have extraneous data added alongside the versioned data in the same map service. But that's just the way I do things and I don't know if that's a "best practice" or not.

AmyKlug
Occasional Contributor III

That did it. Thanks!

0 Kudos
BrianOevermann
Occasional Contributor III

Amy,

Here is my original forum post by which I learned what was necessary:

Publishing a feature service using a versioned feature class

RebeccaStrauch__GISP
MVP Emeritus

Hi Brian,  thanks for adding the ​link to that other discussion.  You should go back and mark one of the answers as correct since you were the original posted in that thread...and Mark the others as helpful so others can follow/find the answer.

0 Kudos
BrianOevermann
Occasional Contributor III

Rebecca, given that my post was created back in 2012, the only actions are to Branch and Report Abuse. I'm fairly certain that I had marked the post "answered" (in 2012) but it doesn't appear that the transition to Geonet retained that status.

I did go and mark posts as helpful. If you know of a way to mark the correct answer on an archived post, please let me know.

AsrujitSengupta
Regular Contributor III

Rebecca Strauch​ & Brian Oevermann​ That thread was marked as a Discussion and not a Question, hence there wasn't any option to select the Correct Answer.

I have converted that to a Question and marked the Correct Answer.