Registering a machine to a site

1124
6
Jump to solution
10-03-2017 07:41 AM
Yi-SzLin
New Contributor

Hello,

I am trying to register a machine to an existing site on a different machine. I am using a domain service account as arcgis server account and the account is an admin on these machines. I checked the account and it has read/write permissions to all arcgisserver folders and config folder. BUT I am still getting this message.

Failed to register the server machine 'xxxxxxx.domain.COM'. Machine 'xxxxxxx.domain.COM' cannot access 'database connection 1', 'database connection 2', 'database connection 3', 'database connection 4', 'database connection 5', ...  data store(s) registered with the site. Please ensure that the ArcGIS Server account has read and write access to the data store(s).

Any thing I am missing. Please help.

Thanks,

Yi

0 Kudos
1 Solution

Accepted Solutions
JonathanQuinn
Esri Frequent Contributor

The SQL Server native client must be installed on each machine within your site, as each Server machine will act as a client to the database.  I would verify that the client is installed on the joining ArcGIS Server machine.

View solution in original post

6 Replies
JonathanQuinn
Esri Frequent Contributor

What type of authentication are you using for those registered data items?  Are you using the same domain account on your joining Server as you are on the existing Server(s)?

0 Kudos
Yi-SzLin
New Contributor

Those registered database connections are using sql accounts. The same domain account is used on both servers and the domain account is an admin on both servers. I am not sure why the domain account on existing server is accessing the data store just fine but the joining server (also using the same domain account) cannot access that data store. I have also used UNC paths for arcgisserver folders and config-store folder.

Thanks,

Yi

0 Kudos
JonathanQuinn
Esri Frequent Contributor

If the registered data stores are using DB authentication, I can't see how they wouldn't have access.  What kind of database is it?  You mentioned SQL accounts, so SQL Server?  Do you have the SQL Server native client installed on the Server?  I would think you'll see a different error specific to the client not being installed, but since this is joining maybe a proper error isn't returned.

0 Kudos
Yi-SzLin
New Contributor

If it were the SQL native client the existing arcgis server site would have the same issue, right? Those registered database connections are are working in the existing arcgis server site. It's just the server to join the site having issues no matter what I do. I have tried all options mentioned above. Is there any other thing I am missing?

0 Kudos
JonathanQuinn
Esri Frequent Contributor

The SQL Server native client must be installed on each machine within your site, as each Server machine will act as a client to the database.  I would verify that the client is installed on the joining ArcGIS Server machine.

Yi-SzLin
New Contributor

Installing SQL Server Native Client on the joining machine solved the issue. Thanks very much for the help.

Yi

0 Kudos