Cannot publish any new image service (see dmp file attached)

275
3
10-04-2017 05:02 PM
MarkMindlin
Occasional Contributor III

Hi,

Local ESRI support cannot reproduce this issue -  please help!

ArcGIS Desktop and Server 10.3.1

Steps to reproduce are ALL in the following list

 

1·         I stopped some running image service (service1)
2·         I opened Service Properties
3·         I pressed Caching---Advanced Settings - crashed

Currently (after 1,2,3), I cannot publish a new image service 
4          I try to publish a mosaic dataset as Image Service (different name from service1)
5·         I have Service Properties opened
6·         I press Caching – crashed (the same error window)

0 Kudos
3 Replies
RebeccaStrauch__GISP
MVP Esteemed Contributor

Although it may not help, I like publishing the service first without caching turned on, then go back in and mess with the cache properties once it is running

Beyond the obvious  reboot or at least restarting ArcGIS Server, sometimes renaming the Status.gdb for a service and letting it rebuild it helps.  I also make sure the services are created in a custom folder and not the AGS root. 

......

I've been messing with creating a new cache from an Image server (10.2.2) and mine was starting to act up, and trying to rebuild the status hung all day.  I finally cancelled it and saw an error that it thought it had lost a connection to the data (which was still up and available).  I have since rebooted and it is working better again.   I rebuilt the status.gdb and no started the cache creation again at the source resolution. (hoping it will work better this time)

0 Kudos
MarkMindlin
Occasional Contributor III

Thank you Rebecca,

Analyze doesn't work (no responce, no error message) 

Press on Publish gets

How we do a reboot of ArcGIS Server? 

We have no Status.gdb yet.

Could you understand from dmp file?

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

I think .dmp files need to be read by tech support (so I didn't try).

re: rebooting...I meant the machine itself...rebooting can clear out any hung or processes that are still hanging around because things didn't complete.  Or, if you can't reboot, you can go to services and stop/start ArcGIS Server...might not be as complete as a reboot, but should help with AGS.  (I rebooted last night since I was having issues with my cache creation....worked better overnight)  Keep in mind that the reboot or restart could take time, depending on how many services you have.

I try to analyze my mosaic database before I created my Image service.... Data Management Tools->Raster->Mosaic Dataset->Analyze Mosaic Dataset.   I used the defaults, but you can have it check other things.  Also, never hurts to update the boundary and make sure you have overviews.

Also, if you plan to move/copy the mosaic dataset to another machine (e.g. from dev to prod), I suggest using the UNC path and not a drive letter, unless you plan to duplicate the data.  We store our data on a shared server and reference that.  just an fyi/suggestion.