Printing Tool Issue

2898
5
Jump to solution
03-26-2019 12:59 AM
User35489
Occasional Contributor III

Hello There,

In Web App Builder, Using Printing Tool from local server fails to generate output(Error, try again) where as Printing Tool from ArcGIS Online works fine. Kindly suggest.

* attached are errors generated while using 'Default Utilities/PrintingTools' service and 'CustomCreatedSecurePrintingTool'

Environment:

ArcGIS Server 10.6 & Portal 10.6 Federated

Web App Builder 2.11

0 Kudos
1 Solution

Accepted Solutions
User35489
Occasional Contributor III

Thank you Tanu for the link. Your suggestion(below) resolved my issue.

It usually happens when your print service can't access http....../..../.../.....

This is what I'd do:

- log on to your server (that hosts your print service) as 'arcgis account user'

- open a web browser

- try to access that map/feature service from there.

View solution in original post

0 Kudos
5 Replies
TanuHoque
Esri Regular Contributor

pls see my response here could help you: Cannot print. Very frustrating problem. 

User35489
Occasional Contributor III

Thank you Tanu for the link. Your suggestion(below) resolved my issue.

It usually happens when your print service can't access http....../..../.../.....

This is what I'd do:

- log on to your server (that hosts your print service) as 'arcgis account user'

- open a web browser

- try to access that map/feature service from there.

0 Kudos
User35489
Occasional Contributor III

Tanu Hoque

Hello,

As i stated above, that i was able to fix the issue by resolving internet access issue on the machine running ArcGIS Server.

Could you please let me know, how to fix this issue if the ArcGIS Server is intended to run in an isolated environment; i.e. ArcGIS Server machine without internet connection

Thanks again

-AS

0 Kudos
TanuHoque
Esri Regular Contributor

if the server hosting print service is in an isolated environment (basically it mean, it doesn't have any access to any service) then I don't think print service would work.

it is just like if you were using arcgis pro or arcmap or you web app in an isolated environment and nothing would work.

0 Kudos
StratosTsarouchis
New Contributor

Hi check if print tool is running with out having load on web map any baseman or services coming through internet.

If you have to have an isolate environment you have to create your own content 

0 Kudos