Password change - invalid password during install SP1 10.1

3878
4
12-03-2012 09:02 AM
MichaelSmith1
New Contributor III
I installed ArcGIS Server Enterprise Advanced on our brand-new 64-bit machine for that purpose (Windows 7 Pro).  Worked great.  Our user policy requires periodic change of passwords, so I changed the password for the arcgis server account using the typical Windows tool for that purpose.

Now I can't install 10.1 SP1, when it asks for the user account (.\arcgis) and the password I get "Invalid Password" error message.  I know this is the right password for the arcgis user, but it is not the same as when I installed 10.1 initially.

I also tried "Configure ArcGIS Server Account" and I can't run that as it also now says "Invalid Password".

This server password is the actual Windows password, right, on the server?  Not the one that you specify later to administer services via the web interface (http://localhost:6080/arcgis/manager/)?  I tried that password too but it also didn't work.

Any suggestions?  Sort of stuck here trying to upgrade to SP1 10.1.
0 Kudos
4 Replies
MichaelSmith1
New Contributor III
Well even tech support couldn't figure out.

But the old uninstall/reinstall did it.
0 Kudos
BubbaHey
Occasional Contributor III
Sometimes you can't beat the good old uninstall/reinstall. When I've gotten that error, what I usually do is reset the password for the ArcGIS Server account.
0 Kudos
DeanMoiler1
New Contributor

I know this thread is a few years old but some enterprises are still using 10.1. I've just had the same issue as you guys, though whilst upgrading to 10.3.1 and was able to get past without uninstall/install.

Here's what I had:

2 x AGS in multi site configuration (10.1)

1 x network service account

1 x network share configuration store

Here's what I did:

I noticed that even during the upgrade to 10.3.1 it was using the correct AD service account and I had confirmed that my password for the service account was correct. I had noticed that it had originally been installed using the local arcgis account.

Firstly I tried setting the ArcGIS for Server service running as a local user, then resetting it in services to AD service account. Unfortunately this didn't work. In the local computer management on the first server I was upgrading I disabled the arcgis user. I then started running the post install and it allowed me to change the user, possibly because the the arcgis user was disabled. I didn't complete the post installation and instead tried going back into the installation, entered the appropriate network password for the AD service account, and it worked! No Invalid Password error.

The installation proceeded until it came to Starting ArcGIS Server service... and hung there for 10+ mins. I stopped the ArcGIS Server service in the windows services dialogue, and the installation was able to finish.

No issues with the password entry on the second server in the AGS site, but it did hang when trying to start the service again.

Hopefully this helps someone!

D

JonCz
by
New Contributor

This 100% worked for me.

0 Kudos