Select to view content in your preferred language

Not able to create portal item with an external WMS

341
3
Jump to solution
04-17-2024 01:28 AM
JonasNeubürger
New Contributor II

I am trying to add an external (password protected) WMS to our enterprise portal.

After being prompted to login, I have been getting the error message, that the service does not exist or is not available. I am able to add this service in ArcGIS Pro with the same url, so it does exist and is available.

I have also added all certificates as mentioned here: https://community.esri.com/t5/arcgis-enterprise-portal-questions/problems-adding-external-wms-refere...

I have also added the wms domain as trusted server, so I am really out of ideas.

Additional info: I am using the latest ArcGIS Portal 11.2

0 Kudos
1 Solution

Accepted Solutions
JonasNeubürger
New Contributor II

Ok, I fixed it myself: The server I wanted to connect to had a faulty CORS config. I only noticed that, because I used the developer console and saw the CORS error pop up when trying to connect to the WMS.

When disabling CORS on my browser (do not do that), I was able to connect to it and create the item.

Maybe the error message displayed by the portal could use some improvement to hint to what the response of the server is.

View solution in original post

0 Kudos
3 Replies
JonasNeubürger
New Contributor II

Ok, I fixed it myself: The server I wanted to connect to had a faulty CORS config. I only noticed that, because I used the developer console and saw the CORS error pop up when trying to connect to the WMS.

When disabling CORS on my browser (do not do that), I was able to connect to it and create the item.

Maybe the error message displayed by the portal could use some improvement to hint to what the response of the server is.

0 Kudos
A_Wyn_Jones
Esri Contributor

@JonasNeubürger For future reference, there is a tool in Portal which can be used to let you know the response that Portal is receiving, it's called the checkURL tool. Here's how you use it:

CheckURL via Portal:

 

  1. Navigate to /portal/sharing/rest to access the Portal directory. This may be disabled, in which case you will need to follow this documentation to allow this. This can be disabled once you're finished with the Portal directory. https://enterprise.arcgis.com/en/portal/latest/administer/windows/disabling-the-arcgis-portal-direct...

A_Wyn_Jones_0-1713428236181.png

 

  1. Login (button is in the top right) and then select Home.
  2. From here, select Portals and then select "CheckURL"
  3. Provide a URL for the tool and select run. You should expect to see a 200 response:

A_Wyn_Jones_1-1713428236182.png

Keep in mind that any secured pages may return a 403 (forbidden error) due to the need to login.

"We've boosted the Anti-Mass Spectrometer to 105 percent. Bit of a gamble, but we need the extra resolution."
0 Kudos
JonasNeubürger
New Contributor II

Thanks for the reply!


I did try that, but got a 200 status code just like you, with secured=false (and a 403 when I used a private window, where I was not authenticated). That's also why I was confused about it not working.

0 Kudos