Multipatch layers fail to load in Portal webscene

872
3
05-01-2021 12:17 PM
DianeBird
New Contributor III

We have a recent Enterprise deployment and are having difficulty when publishing a 3D scene with a multipatch layer from ArcGIS Pro 10.8.1.  The publishing reports "success" and the scene is listed in the content section of our portal.  However, upon opening the webscene, the basemap is visible and a message pops up that the "xxxx layer could not be added". When attempting to add the layer manually via the URL, the same message appears.

On the other hand, ARC Catalog will preview the datasets published in the "Hosted" services section under the ArcGIS Server used. (The server is federated to our portal.)

This is a relatively small multipatch layer that was exported out from a dwg file as a featurelayer in a new geodatabase. The max record count is 2000.

Any ideas??

Tags (2)
0 Kudos
3 Replies
BrianE
by
Occasional Contributor II

I believe I had that problem before. While the layer might say it has been uploaded it really has not. Give it a few minutes and try to load into your scene again. 

I had brought this issue to Esri over a year ago but looks like its still an issue

0 Kudos
Tim_McGinnes
Occasional Contributor III

Does it need to be published as multipatch features? An alternative is to use the Create 3d Object Scene Layer Package tool and publish as a hosted scene layer.

0 Kudos
ThomasJones1
Esri Contributor

Hello @DianeBird,

To gain more insight I would recommend reviewing the ArcGIS Server logs after attempting to open the scene layer in the scene layer viewer. If your familiar you can also use browser developer tools to review the network traffic when attempting to load the scene layer. 

A couple follow up questions:

  • What coordinate system are you using for your scene layer?
  • Are you publishing a hosted or referenced scene layer?
  • Does your tile cache data store successfully validate?

You can also publish a scene layer by running the create scene layer package tool in ArcGIS Pro and then uploading the scene layer package to portal as an item. You may want to try this workflow as a test to see if you get any different results.

ArcGIS Pro - Create 3D Object Scene Layer Package (Data Management)

Otherwise I would recommend creating a support case for assistance with further troubleshooting.

Hope this helps!

Thanks,

Thomas.

 

 

0 Kudos