Select to view content in your preferred language

Methods to Troubleshoot Failed Attachment Uploads?

638
2
Jump to solution
07-20-2023 12:34 PM
Matt-Huser
Occasional Contributor

From time to time, I've had Field Map users have reported an error message that their attachment failed to upload.  I've verified that the geometry and attribution updates have made it back to the SDE database and that their photo size is set to medium.  The ArcGIS Server Logs, as far as I can see, only log successful attachment uploads. I'm not seeing anything pertaining to failures.

I'm not sure what other steps I can take to troubleshoot the matter other than making sure they have better data coverage at the time of upload or having them continue to hit resubmit until the upload is successful.

Any ideas?

0 Kudos
1 Solution

Accepted Solutions
David_McRitchie
Esri Contributor

There are a lot of reasons that this might happen, generally things I would always check are the following.

 

  • Does the Server and Database machine have enough space? Image attachments can quickly erode at this.
  • Is it happening on just one Field Maps project or numerous projects?
  • Is there anything in common between images uploading and not uploading? Things such as device, OS, Image size and format might narrow the issue down.
  • Is the upload issue happening on mobile data or can it be reproduced on a dedicated WiFi network.

If these do not narrow the issue down then utilising the error logs in Field Maps will provide a clearer reason. You can find this on the Field Maps app via Profile > Troubleshooting > View logs.

Hopefully that helps!

David

Esri UK -Technical Support Analyst

View solution in original post

2 Replies
David_McRitchie
Esri Contributor

There are a lot of reasons that this might happen, generally things I would always check are the following.

 

  • Does the Server and Database machine have enough space? Image attachments can quickly erode at this.
  • Is it happening on just one Field Maps project or numerous projects?
  • Is there anything in common between images uploading and not uploading? Things such as device, OS, Image size and format might narrow the issue down.
  • Is the upload issue happening on mobile data or can it be reproduced on a dedicated WiFi network.

If these do not narrow the issue down then utilising the error logs in Field Maps will provide a clearer reason. You can find this on the Field Maps app via Profile > Troubleshooting > View logs.

Hopefully that helps!

David

Esri UK -Technical Support Analyst
Matt-Huser
Occasional Contributor

Appreciate the response David, I forgot about the Logs. Next time this happens, I will dig into them.

0 Kudos