Select to view content in your preferred language

Trace Network Problem

572
3
07-31-2023 02:53 AM
slopezna
New Contributor

Hi there, I need some help.

I want to publish a trace network service, I have tried creating the trace network and it was working properly, but now I am facing some issues, after executing the "Create Trace Network" tool, when I try to set the starting points, that tool appears "blocked"starting_points.png

That did not happen to me before.

In addition, if use as starting points an already existing shapefile, i find the following error:

error.png

And also, i don't know if this last example has anything to do with the previous errors but I cannot edit a new point feature class in the enterprise geodatabase:

error_3.png

Any suggestion??

Thanks in advance

0 Kudos
3 Replies
MikeMillerGIS
Esri Frequent Contributor

I am not as familiar with the trace network as I am the utility network, but I think they have the same restrictions.  You must publish the trace network to a feature service to trace and edit once versioned.

0 Kudos
slopezna
New Contributor

Hi Mike, some questions if you don't mind:

- What you mean is that once versioned, I cannot use the trace tool in ArcGIS Pro?

- After publishing (I have already done it as WebLayer) how and where am I able to use the trace tool? or in your case, the utility network?

Im quite new to this

Thanks mate!

0 Kudos
MikeMillerGIS
Esri Frequent Contributor

You need to publish a feature service and create a map from that.  https://pro.arcgis.com/en/pro-app/latest/help/data/trace-network/publish-and-consume-services-with-a...

 

0 Kudos