Level 1 Users Cannot Access Referenced Data

46
1
01-24-2020 05:31 AM
Highlighted
New Contributor II

I have an ArcGIS Enterprise 10.5 environment with a SQL server Enterprise Geodatabase.  Most of the users of Portal are Level 2 publishers or creators.  There have been numerous apps and dashboards created using published, referenced feature layers using data from the SDE with no access issues until now.

With a recently created feature service and Dashboard I have a small group of level 1 viewers who cannot load the feature service in either the dashboard or a stand alone web map.  They can see the feature service since it is shared to the group that they are in, but when a level one user attempts to load the feature layer in a web map they receive the error message saying the data could not be loaded into the map.

Here are the details about the layer.  It is a SQL view of one spatial and one non-spatial table both in the same database.  Neither of the tables are versioned.  It is published to Portal using ArcMap 10.5 as referenced data.  All level 2 users can access it and use the Dashboard that contains it.  My thoughts are that it has something to do with permissions on the tables in the database, but I don't know exactly.

Reply
0 Kudos
1 Reply
Highlighted
New Contributor II

Here is the answer:

The original view was published using an SDE connection with a user that had write capabilities enabled.  Portal didn't give level 1 users access to the data because of this.  A new database user had to be created with read only access to the database.  The new SDE connection with the read only user was registered with the AGS and a new service was published with the view added to ArcMap using that read only connection.  The old feature service was replaced in the webmaps/dashboards with the newly published service so that level 1 users could access the data.

Note:  The old service could not simply be overwritten using this new connection.  It would not update the service properties.  A new feature service had to be created in order for it to work.

Reply
0 Kudos