Is ArcGIS Pro missing some maplex labeling functionality when publishing a Map Image Layer to ArcGIS Enterprise (Server)?

815
4
Jump to solution
03-29-2022 02:43 PM
BrianFausel
Occasional Contributor III

In ArcMap I am able to use the Maplex labeling engine to rotate labels on a point layer. I can then publish this MXD to become a Map Image Layer (MapServer) in ArcGIS Enterprise (Server) and the labels in the service display the label rotation.

If I try this same thing in ArcGIS Pro with the Maplex labeling engine turned on my label rotation displays properly in the Pro APRX project but the resulting Map Image Layer displays the labels horizontally (i.e. the rotation is removed). If I change the Pro labeling engine back to the Standard one and publish as a Map Image Layer then the rotation works. Though now I loose the enhanced capabilities of the Maplex engine.

Esri documentation states that the Maplex engine is available in Pro but only recommended for cached maps. Even if cached is the recommendation, I'm still curious to know if Maplex is supported in non-cached services (Map Image Layer) as it was in ArcMap.

Is this a bit of functionality that Pro is missing? Is it possibly related to the versions I'm using?

ArcGIS Pro version 2.9.2 (latest update)
Enterprise (ArcGIS Server) version 10.7.1  (perhaps this older version is the culprit?)
Enterprise database (SQL Server) version 10.8.1

Thanks!

 

0 Kudos
1 Solution

Accepted Solutions
TanuHoque
Esri Regular Contributor

@BrianFausel 

Would you mind try on a new version of ArcGIS Enterprise? I just tried on 10.9.1 and it worked for me, unless I missed any critical steps. 

Thanks

View solution in original post

0 Kudos
4 Replies
TanuHoque
Esri Regular Contributor

@BrianFausel 

Would you mind try on a new version of ArcGIS Enterprise? I just tried on 10.9.1 and it worked for me, unless I missed any critical steps. 

Thanks

0 Kudos
BrianFausel
Occasional Contributor III

Hello @TanuHoque 

Thanks for checking. I can try it on a 10.9.1 ArcGIS Enterprise at another office I work at but won't be able to do so right away. Hopefully within the next week...I'll post results.

The steps I did were:

- Create map in Pro (APRX) with a point layer coming from MS SQL Server.

- Create labels and using Maplex set up rotation based on an attribute field.

- Publish to ArcGIS Enterprise (Server)

- In Enterprise 10.7.1, the rotated labels flip back to horizontal (rotation is removed)

Thanks!

 

0 Kudos
TanuHoque
Esri Regular Contributor

@BrianFausel 

I tried attribute rotation too and that worked for me as well. No rush, please give the newer version a try when you get a chance and let us know what you find.

TanuHoque_0-1648655440637.png

TanuHoque_1-1648655447203.png

 

0 Kudos
BrianFausel
Occasional Contributor III

Just tried it on our already existing 10.8.1 at that other office and it does seem to be working there. As you mentioned in that other thread about Composite Callouts it looks like the maplex functionality was enhanced at 10.8.1. I'll try it again after upgrading to 10.9.1 but I would expect that it will still work.

Thanks!