Indices in republished map service change

02-10-2021 06:19 PM
Occasional Contributor II


Not sure this is the proper location for this question.

We have several map services published that are used in a web map then in a web app for end users to view the data in the enterprise system.

Every now and then, things change - feature classes added or dropped, fields added or dropped in the sde - when the map service is republished sometimes the indices change numbers and will not necessarily be sequential either.  They can go from sequential 0, 1, 2, 3 ... then upon republish change to 0, 1, 732, 733, etc.

What causes this?  It is extremely aggravating as it will also break many of the widgets in the web app and they have to be updated, or edited for the new index number.  Is there a way to eliminate this?  We are currently using V10.7.1 Server/Portal and desktop.  We currently publish with ArcMap.  We have tried in ArcPro but the indices seemed to still change.  Also, ArcPro seems to take about 3 or 4 times LONGER to publish the map service.




1 Reply
Occasional Contributor II

Hi LorindaGilbert,

Have you tried using the 'Allow assignment of unique numeric IDs for map service publishing' setting in the layer?

For ArcMap:

See this blog for ArcGIS Pro settings: