Select to view content in your preferred language

IIS for Enterprise

321
3
Jump to solution
05-25-2023 01:36 AM
Erdem_Yurdakul
New Contributor II

Hello friends,

I need your expertise to be sure about a question. My organization has ArcGIS Enterprise 10.8. It's installed on seperate machines. Every machine has Internet Information Services (IIS) and I'm not sure that all machines have to have IIS installed. According to document's Install and Deployment part, I understand that Web Adaptor needs to IIS. Do we have to install IIS to all machines when the structure builds on seperate machines?

Thanks.

0 Kudos
1 Solution

Accepted Solutions
Scott_Tansley
MVP Regular Contributor

if we're talking 'purely' ArcGIS Enterprise, then yes, it's only needed on the Web Adaptor machine(s).  I've seen people host other things on IIS on other machines, that may be bespoke apps.  So confirm that there is no content in IIS before disabling.

Scott Tansley
https://www.linkedin.com/in/scotttansley/

View solution in original post

0 Kudos
3 Replies
Scott_Tansley
MVP Regular Contributor

if we're talking 'purely' ArcGIS Enterprise, then yes, it's only needed on the Web Adaptor machine(s).  I've seen people host other things on IIS on other machines, that may be bespoke apps.  So confirm that there is no content in IIS before disabling.

Scott Tansley
https://www.linkedin.com/in/scotttansley/
0 Kudos
AyanPalit
Esri Regular Contributor

@Erdem_Yurdakul Please refer to ArcGIS Web Adaptor 11.1 system requirements

IIS required components are stated.

In a distributed setup, IIS is not a must on all machine but is dependent on the architecture requirements. 

Review ArcGIS Enterprise system requirements as well 

Ayan Palit | Principal Consultant Esri
Erdem_Yurdakul
New Contributor II

@Scott_Tansley  and @AyanPalit Thank you for your answers.

Best Regards.

Erdem Yurdakul

0 Kudos