How to change web adaptor name for Portal

2120
2
02-21-2019 08:43 AM
AndreaV
New Contributor III

Hi, 
I have an installation of ArcGIS Enterprise, Single Server Deployment, federated and with hosting server. It's an upgrade from 10.4 to 10.5 and now to 10.6.1, with a lot of Map Service, Web Map and Web Map Application published.
I inherited a configuration with web adaptor for IIS configured with same name for Server and Portal ("/arcgis") that in 10.4 seems was not an issue.
Now I would fix that and install two distinct web adaptor: "/arcgis" for server and "/portal" for Portal, as for 10.6.1 installation guide.

 

I have done these steps:
1. unregister Web Adaptor from Portal via REST portaladmin interface
2. unregister Web Adaptor from ArcGIS Server via REST admin interface
3. uninstall ArcGIS Web Adaptor for IIS from Windows
4. Install first instance of Web Adaptor in "/arcgis" (same as before) and register with ArcGIS Server
5. Install second instance of Web Adaptor in "/portal" and register with Portal

 

Then I had to fix an issue where the old url were invoked for generate token to access Map Services, I found it in "\arcgisserver\config-store\security\security-config.json and I manually substituite "/arcgis" with "/portal" and restarted ArcGIS Server.

 

"portalProperties": {
"portalUrl": "https://<FQDN>/portal",
"privatePortalUrl": "https://<FQDN>:7443/arcgis",
"portalSecretKey": "xxx",
"portalMode": "ARCGIS_PORTAL_FEDERATION",
"serverId": "6UDp3Xo8LUVf4XqY",
"serverUrl": "https://<FQDN>/arcgis",
"webgisServerTrustKey": "xxx"
}

 

Now Portal seems to works with the new web adaptor name, BUT all Web Mapping Application don't open, they show this error on browser:


Unable to load //FQDN/arcgis/sharing/rest/portals/self?f=json&token=g3xCGAD7L_ZYhx9TM55aBth19FmO_-VqIf3fhPlXfCQxhYyPKaLlVsZNlhcZdxbdyNINwkcN9MIiFwHWxUlUSCkVm5-YBU9UYwVcxr0AK-xVDYYRYHA0sPnRE9-_67d1A-l6OuEoCwdpJK1djPwfYxZbDWVf3qGfspcrdsDNGTr6pWAPA065V2D2khiHcqGJ&dojo.preventCache=1550755853005 status: 500

 

If I copy and paste that uri with "/portal" instead of "/arcgis" I obtain a right response.

 

Where can I fix that setting for saved Web Mapping Application?
I'am looking on file system and in the embedded PostgreSQL without success.

 

Or what is the right way to rename the Portal web adaptor ? thanks.

0 Kudos
2 Replies
JonathanQuinn
Esri Frequent Contributor

You can use Python to loop through the Sharing API and update the URLs for web apps to point to the new URL. A few of the examples for the Python API have code to loop through users and content so they can be used as a starting point:

move_existing_user_content_to_a_new_user | ArcGIS for Developers 

https://developers.arcgis.com/python/sample-notebooks/clone-portal-users-groups-and-content/

AndreaV
New Contributor III

Hello Jonathan,

thank you for answer, the URL that opens the web application, inside the Web Mapping Application settings, is correct but I get an error for an inside url. I attach some screenshots:

here you can see the wrong /arcgis/sharing/rest/...  URL, where come it from?

0 Kudos