How do I add 10.3.1 Image services to Google Earth?

3871
13
07-28-2016 05:26 PM
PaulHuffman
Occasional Contributor III

A few years ago,  when I was running Arc Server 9.3.1,  I was able to publish image services with WMS enabled,  then add them to Google Earth as an image overlay https://support.google.com/earth/answer/148099?guide=22373&ref_topic=22376​ (but the content at this link location has been updated,  doesn't match what I had been telling users to do back then.)  My image services would work pretty well for my users who only had Google Earth.

Now with ArcServer 10.3.1,  I have some image services of mosaics published with WMS checked, overviews built,  and they scale up and down just fine in ArcGIS 10.3.1.  But when I try adding my new services to Google Earth Pro by listing my rest services in a browser at http://myserver:6080/arcgis/rest/services , selecting the image service and the View in Google Earth option,  the WMS service opens in Google Earth,  but it doesn't look like it jumps to the more detailed pyramids at larger scales.   It seems stuck at about 1:31000.   Is there a new way to add these 10.3.1 image services to Google Earth?

0 Kudos
13 Replies
PaulHuffman
Occasional Contributor III

I just added my WMS services to ArcCatalog 10.3.1 for testing the WMS service,  and in preview, it scales write up until I can read the fine print. Performs as expected.  It must be something different about Google Earth Pro now. 

0 Kudos
PaulHuffman
Occasional Contributor III

Also tried looking up the url of the WMS in ArcServer Manager and adding it to Google Earth by Add>Image Overlay.  All I get is the big red x in Google earth.  Tried both the http://myserver:6080/arcgis/services/WIP78Mosaic/ImageServer/WMSServer  and the

http://localhost:6080/arcgis/services/WIP78Mosaic/ImageServer/WMSServer

on the ArcServer machine as possibilities. 

0 Kudos
RandallWilliams
Esri Regular Contributor

Is Google Earth maybe looking for a URL to the capabilities document?

http://localhost:6080/arcgis/services/WIP78Mosaic/ImageServer/WMSServer?request=GetCapabilities&service=WMS

0 Kudos
PaulHuffman
Occasional Contributor III

That url just got me a "WMS Capability fetch failed" from GE add overlay. 

0 Kudos
PaulHuffman
Occasional Contributor III

The work flow provided by ESRI Customer Care is:

  1. In Google Earth, go to Add > Image Overlay.
  2. Add a name and the URL of the WMS Service in the Link field.
  3. In the Refresh Tab, click on the WMS Parameters button.
  4. In the “Web Mapping Services Parameters” window, click Add.
  5. Add the URL to the WMS service again as in step 2.This will connect to the service and list the layers in the Opaque layers column.Those can be moved to the Selected Layers column.Click Apply, then OK.Click OK once more.

Which is more complete that what I have been looking at from Google Earth:  https://support.google.com/earth/answer/148099?guide=22373&ref_topic=22376

Even though it now works as an image overlay, it works somewhat worse than the  link in the rest services page for the service to "View in: ....  Google Earth" which passes a kmz link.  Like the view in Google Earth link, the WMS overlay doesn't seem to zoom to higher resolutions,  and worse than the link, sometimes draws a blank across the bottom of the GE window.

The WMS service zooms down to large scales in ArcCatalog.  https://www.dropbox.com/s/l6pbrctpduzsokx/screenWMS.jpg?dl=0

PaulHuffman
Occasional Contributor III

ESRI Customer helped me with a trick.  Edit the HEIGHT and WIDTH values in the url used from AS to set up the image overlay in Google Earth to get more resolution at larger scales.  For example,  http://nsmap:6080/arcgis/services/WIP78Mosaic/ImageServer/WMSServer?VERSION=1.1.1&REQUEST=GetMap&SRS...

The maximum HEIGHT and WIDTH values possible for ArcGIS Server WMS Services are 4096 X 4096.  Increasing HEIGHT and WIDTH will increase your Google Earth draw times,  so try a few values until you get a good balance between draw time and resolution.  

PaulHuffman
Occasional Contributor III

It's too bad this Geonet system took the url string I typed and turned it into a link while truncating its content. I can't figure out how to reveal the complete string now.  Following the link doesn't go anywhere, and doesn't show the original url string. How was I supposed to enter this as an example, not as a unfathomable link?  As a source code block?

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

That seems like a Jive bug (from the last update on the 12th?).  I notice we no long have the options when we hover. 

pinging timothy_hales-esristaff

0 Kudos
TimothyHales
Esri Notable Contributor

GeoNet creates an auto title for urls, so if the page does not contain a title it uses the URL. These hyperlinked titles are limited to 120 characters. To display the entire URL, you will need to make sure the Bare URL option is selected instead of Auto-title.

http://nsmap:6080/arcgis/services/WIP78Mosaic/ImageServer/WMSServer?VERSION=1.1.1&REQUEST=GetMap&SRS... 

0 Kudos