Hi, I have question about Geoprocessing service publication.

598
2
06-21-2017 04:58 AM
MiroslavKopecky
New Contributor

I have prepared toolbox with one toolset and one Python script (tool) is included in this toolset. If I run this tool from ArcMap, it is run correctly. But if I try publish it as geoprocesing service (in the ArcGIS server 10.0), there is problem. Service is created and it is visible via ArcCatalog, but I am not able start it. During geoprocessing service creation I got these messages:

The following GIS Services will be created and started:

qc_servis/qc_tool_test_10.gp 

The following are the URLs for the service capabilities:

http://192.168.2.213/qc_servis/qc_tool_test_10/GPServer.

It looks optmistical... But in the next step I got this message:

Configuration qc_servis/qc_tool_test_10.GPServer can not be started.

Configuration qc_servis/qc_tool_test_10.GPServerSync can not be started.

Server Object instance creation failed on machine hadar1. 

The toolbox did not load: C:\arcgisserver\arcgisinput\qc_tool\qc_tool_test_10.tbx 

Server Object instance creation failed on machine hadar. 

Geoprocessing service initialization failed.

Invalid parameter:

Tool - CRS_test : Parameter - Input folder : Data Type - Folder Invalid parameter:

Tool - CRS_test : Parameter - Input geodatabase : Data Type - Workspace

Invalid parameter: Tool - CRS_test : Parameter - Output folder : Data Type - Folder.

Thank you for any help.

0 Kudos
2 Replies
JonathanQuinn
Esri Frequent Contributor

I think you'll have to take a look at what parameters you have and if they're allowed in the Server environment.  The documentation for 10.0 is a good place to start, as it describes a situation where that error is thrown.

You may want to also check the latest documentation for GP services, as 10.0 doesn't describe folders or workspaces as being invalid, but the latest documentation describes them as "non-transportable", meaning they have to be hardcoded:

Input modes and parameter data types—Documentation | ArcGIS Enterprise

MiroslavKopecky
New Contributor

Hi Jonathan, thank you for answer. I changed all input parameters as "String", problem mentioned above was solved, geoprocessing service was created, but it is not started. ArcGIS server write this Error message:

Configuration qc_servis/crs.GPServer can not be started.


0 Kudos