Help with The layer, ##, cannot be added to the map. in AG Base Deployment

199
0
08-26-2019 05:49 AM
FernandoBenitez
New Contributor II

Does anyone can help me with this error (image attached) "The layer, TestTNC2_MIL1, cannot be added to the map."

I have implemented an AG Enterprise Base deployment (one-single machine) and initially, everything was ok. Except that once I started to create a webmaps and adding the feature services published from ArcGIS Pro, I got an error message that the layer cannot be added. I did some research here in Geonet I found this (THE LAYER (LAYER NAME) CANNOT BE ADDED TO THE MAP" )  and Error: The Layer, ######, cannot be added to the map  mentioned that the issue could be a mixing HTTP and HTTPS content, initially I thought that this could be the issue, despite I've never got this issue when pressed f12 to open Dev tools in Chrome. Although I kept working on that and then I include a signed certificate in my portal following the instructions from Import a certificate into the portal—Portal for ArcGIS (10.7 and 10.7.1) | ArcGIS Enterprise. Unfortunately, the issue is still there and now I have no idea what needs to be done to solve this issue. One important test is: If I copy the link of my REST service, and added to my web map, it works. but if I'm using the option of add layer from my Map Viewer or I launch the item content to display in a Webmap then I got the error. So far I have a little mess with the certificates and also I have included the signed CA certificate after the ArcGIS Base Deployment was installed, I don't know if I need to run any of the installers to clean up the environment. So I ran out ideas, and I really appreciate your help. if you can guide me with a list of steps or things to validate to solve this issue, would be amazing. Error: The Layer, ######, cannot be added to the map

by the way, I have also tried Create a domain certificate—Portal for ArcGIS (10.7 and 10.7.1) | ArcGIS Enterprise  but even having installed the signed-CA certificate I got always the error in PowerShell 
Unable to determine certificate authority (CA) for this domain.  So I couldn't finish this process.

I have also the same issue with the feature services created adding item in the Portal. They do not allow to be added in the web map, but when I look at the URL services and add as Webservices it works. Seems to me is something easy to fix, but I have no idea.

I'm enclosing the links, some images to guide you through this issue and get a proper response.

Portal: https://citydata.init.uji.es/portal/home  (here you can see that has a validate and Signed-CA certificate, now is a safe place for chrome)

Service URL trying to add: https://citydata.init.uji.es/server/rest/services/TestTNC2_MIL1/MapServer 

FeatureService: https://citydata.init.uji.es/server/rest/services/Hosted/MuestraAvaluos2/FeatureServer 

0 Kudos
0 Replies