Select to view content in your preferred language

Getting "Could not access any GIS Server machines" with Web Adaptor.

24221
19
Jump to solution
03-25-2015 11:59 AM
DonnyVelazquez
Occasional Contributor

I'v installed the Web Adaptor on the iis web server which sits in a DMZ. The ports 6080 & 6443 are open in the firewall to ArcGIS Server. I have checked using a port scanner and have accessed the rest services directory from

"http://[arcgis server machine name]:6080/arcgis/rest/services"

.

But when I try to access the same rest services directory from

"http://[web server name]/arcgis/rest/services"

I get the "Could not access any GIS Server machines. Please contact your system administrator." error.

The weird thing is it lets me add arcgis server with no problem. I did have to edit the windows host file so that the arcgis server machine name would resolve. Since the web server is sitting in a DMZ.

Does the web adaptor need any other ports open?

System info

ArcGIS Server 10.3

Windows Server 2012 R2

IIS 8.5

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
DonnyVelazquez
Occasional Contributor

So not only did I have to add a host entry in the windows host file for the machine but also for its

fully qualified name. machinename.domain.com

View solution in original post

19 Replies
JayantaPoddar
MVP Esteemed Contributor

Has the ArcGIS Web Adaptor been correctly configured with ArcGIS Server?



Think Location
0 Kudos
DonnyVelazquez
Occasional Contributor

Yes when I add it in the Web Adaptor configuration page the green box popups up with the link.

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

What is the Web-Adaptor name? Try replacing "arcgis" with the webadaptor name in

"http://[web server name]/arcgis/rest/services"



Think Location
0 Kudos
DonnyVelazquez
Occasional Contributor

That is its name.

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Also

ArcGIS for Server communicates on ports 6080 and to interact with web Server it needs 8080. You'll need to open these ports on your firewall before installing the software.



Think Location
0 Kudos
DonnyVelazquez
Occasional Contributor

So for ArcGIS Server to talk back to the Web Adaptor it does it on 8080?

Is there a ESRI doc that you can reference for that?

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

I hope, you have installed the web-adaptor in your web server.



Think Location
0 Kudos
RebeccaStrauch__GISP
MVP Emeritus

If by chance your web adapter is set up as secure.....try.  Https.   Instead of http. ​

https://<web-server-URL>/<web-adaptor...which may not be the default ArcGIS>/rest/services

keep in mind however, if you have disabled the rest services thru the web adaptor, as recommended in the security documents, you will get an error and not be able to see rest endpoints.  That will be the case whether inside your network or not.

0 Kudos
DonnyVelazquez
Occasional Contributor

Its not setup with SSL and the rest service is not disabled.

0 Kudos