Failed to extract manifest from uploaded service definition.

08-16-2017 09:16 PM
New Contributor III


While publishing service on ArcGIS Server getting following error. 

ERROR 001362: Failed to extract manifest from uploaded service definition.

System configuration are as follows.

ArcGIS Server 10.4.1

ArcGIS Portal 10.4.1

ArcGIS Desktop 10.4.1

Window server 2012 r2

Previously services were publishing successfully. Above mentioned issue has appeared recently.

0 Kudos
3 Replies
MVP Esteemed Contributor

001362: Failed to extract manifest from uploaded service definition.—Help | ArcGIS Desktop 


The server-side publishing tool was unable to extract and deserialize the manifest from the uploaded service definition file (.sd). This could happen if the server deleted a service definition based on the last accessed time stamp before the service is published. This could also happen with large service definitions, since they are uploaded in parts. When the first part is uploaded, the server assigns an uploadID to it. When all parts are uploaded, the server concatenates the parts into a whole. If an error occurred during this process, the result could be an ID pointing to a nonexistent or corrupt service definition.

This server system tool is invoked by the publishing client (Manager or ArcGIS Desktop) when you create a service.


Re-create the service definition file (.sd) and publish again.

Restart ArcGIS Desktop and try the above solution.

Think Location
0 Kudos
New Contributor III

Hi Jayanta,

I have tried that solution but did not get any success.

0 Kudos
Occasional Contributor III

I understand that you are trying to publish a map service from arcgis desktop 10.4.1 to arcgis server 10.4.1 and that is when you receive the error message.

Can you check if the publishing tool available in the System > PublishingTools is running. If it is running try to publish a sample map service and check if it throws the same error message.


0 Kudos