Failed to execute Geoprocessing on ArcGIS Server

1020
8
07-25-2017 08:44 AM
AnasELMALEKI1
New Contributor II

Hi,

I am trying to publish a working model created using Model Builder which returns a significant result when executed on ArcMap. After having published the model on the ArcGIS Server, it doesn't work, here are some snapshots :

Model Builder

Execution on ArcMap and visualization (red rectangle)

After publishing the geoprocessing (executed from "orange box")

We get a error message (red circle)

We need help please.

Thanks in advance.

0 Kudos
8 Replies
JonathanQuinn
Esri Frequent Contributor

Have you looked at the link on troubleshooting GP services?  The section on enabling Info level messages will be particularly useful.

AnasELMALEKI1
New Contributor II

Thanks, I activaed info, here's the message :

I couldn't resolve the problem.

0 Kudos
JonathanQuinn
Esri Frequent Contributor

So Google Translate tells me that the error is "Invalid return value".  Is that correct?  If so, can you check the directory manually using ArcMap or ArcCatalog and verify that the data it's expecting is in the scratch geodatabase?  Basically, follow the path in the error to see if the data is there, which is outlined here.

AnasELMALEKI1
New Contributor II

You're right, the error is invalid return value.

I explored scratch.gdb, I found that it doesn't contain any result of the geopocessing.
Is it a problem of writing permission?

0 Kudos
JonathanQuinn
Esri Frequent Contributor

It's a character issue.  

I doubt FGDB feature class names support an accented e.

AnasELMALEKI1
New Contributor II

I tried the same process with a simple e, it didn't work.

0 Kudos
JonathanQuinn
Esri Frequent Contributor

You can simplify this and just take the input data and save it to the scratch workspace.  If that works, then I'm not sure why it wouldn't when you add the rest of the tools.  You may want to reach out to technical support.

0 Kudos
Dr__Syed_AliNaqi
New Contributor III

Have your problem solved?? I have one clue for the solution but I need your model snap/pic in English version before final statement.

0 Kudos