Error when registering PostgreSQL database with ArcGIS Server

1073
4
09-10-2019 03:35 AM
JillSlater3
New Contributor III

I am trying to register a PostgreSQL database with our ArcGIS Server v. 10.7. I get the following error message: "The connection property set was missing a required property or the property value was unrecognized. Instance not available on the server".

I can connect to the database fine from ArcCatalog on client machines, but I also get an error when I try and connect via ArcCatalog on the server: "Connection timed out. Is the server running on hose <postgresql db servername> and accepting TCP/IP connections on port 5432? SQLSTATE="

I have updated the pg_hba.conf to include the IP address of both the arcgis server and also the portal machine that has the web adaptor installed (our server is federated with Portal). I also confirmed that the postgreSQL login user that I am connecting with has the correct privileges and is the owner of a schema in the database, as per the ESRI documentation.

What am I missing that is preventing me from registering the database with the arcgis server?

0 Kudos
4 Replies
PanGIS
by
Regular Contributor

Hi,

have you checked whether your PostGRE vesion meets the minimum requirement for 10.7?

PostgreSQL database requirements for ArcGIS 10.7.x and ArcGIS Pro 2.4—System Requirements | ArcGIS D... 

0 Kudos
JillSlater3
New Contributor III

Our PostgreSQL version is 9.6.10, so it seems like it meets the minimum requirements for 10.7 and Pro 2.4.

0 Kudos
George_Thompson
Esri Frequent Contributor

The min. supported Postgres version is 9.6.12. Can you upgrade to 9.6.12 from x.x.10 and retest?

It is possible there is something in a lower version causing the issue.

--- George T.
PanGIS
by
Regular Contributor

No,

it does not meet the minimum requirements.

I had a similar issue when I upgraded to server 10.6.1 and my PG was 9.5.10: I was not able to register my database into server.

I would recommend to upgrade.

0 Kudos