Error HRESULT: 0x80040501 when adding excel files

4865
13
Jump to solution
01-15-2020 07:49 AM
IreneFernández_López
New Contributor

When I try to agregate an Excel File to ArcGIS Pro it comes out an error with the message: Exception of HRESULT 0x80040501.

It doesn't show any details on the error. I have already installed the Access Database Engine Controller, but I can't find where this error comes from.

Can anyone help me with this?

Thank you.

0 Kudos
1 Solution

Accepted Solutions
VictoriaAnderson
Esri Contributor

Do you have 2 versions (64 and 32 bit) of Microsoft Access Database installed? If so, can you uninstall both versions and reinstall just the 32 bit? 

View solution in original post

13 Replies
VictoriaAnderson
Esri Contributor

Do you have 2 versions (64 and 32 bit) of Microsoft Access Database installed? If so, can you uninstall both versions and reinstall just the 32 bit? 

IreneFernández_López
New Contributor

That was the problem! Thank you so much!!!

AlexRudowski
New Contributor III

I get this same error sometimes when I'm trying to save a new ArcPro project. I'm not sure what the Access driver has to do with my situation, but I checked and I only have the 32-bit version on my machine. The error message appears, but sometimes if it sits for about five minutes with the error message up the project will finally save. I'm working in 2.7.3 but will soon update to the newest version.

Hresult.pngODBC.png

Thanks

ZacharyHart
Regular Contributor

having the exact same issue still. @AlexRudowski  did you ever find a solution?

AlexRudowski
New Contributor III

I'm not getting the error anymore, but I'm still having the issue where it takes forever to save. Sometimes it just spins and never saves at all :thinking_face:

 

AlexRudowski
New Contributor III

@ZacharyHart I'm getting the same error again this morning. I'm still on 2.7.3, so I think I'm going to move to the newest version. What version are you running?

ZacharyHart
Regular Contributor

same version still 2.7.3. If the upgrade process didn't break my dev environment every single time you upgrade, I'd make the jump much more often.

RafałRokicki
New Contributor II

Hello,

i have same problem and same error, but after reinstall whole Office and install Standard x64 (without Access) instead of Profesional x32 (with Access) i still have this error

VictoriaAnderson
Esri Contributor

Could you try uninstalling the 64 and install the 32 instead? 

0 Kudos