Error 00210: Server cannot write to Scratch.gdb in arcgisserver folder

10-09-2019 09:18 AM
New Contributor III

I recently created a model to be published as a geoprocessing service which will take a number of feature classes and perform several processes and rewrite them back to our server.  When I run the model, everything works correctly and I can publish the service with no issues.

The issue is that when I run the process on our server, it fails and writes the following error code in the server log:

Error executing tool. Land_Type_Acres Job ID: jd17fece367bc42e69c34a27e144faade : ERROR 000210: Cannot create output c:\arcgisserver\directories\arcgisjobs\assessing\ltacreage_gpserver\jd17fece367bc42e69c34a27e144faade\scratch\scratch.gdb\LandType_Scratch\temp_int_woodland Failed to execute (Intersect (2)). Failed to execute (LTAcreage). Failed to execute (Land_Type_Acres).

I have attempted to work with the environment settings in the tool to change the scratch.gdb, have tried making the model work in a local geodatabase only, and allowed data store access to the arcgisserver folder.  Nothing seems to work.  

0 Kudos
2 Replies
Esri Contributor

Hi Christopher,

How many machines are in this ArcGIS Server site? Is the account that is running the ArcGIS Server Windows Service(s) a local acccount or a domain account?

0 Kudos
New Contributor III


There is only one machine and it appears to be a domain account that is running the ArcGIS Server Windows Service.

Thank you,


0 Kudos