Drawing Info for Feature Service is not updating in REST service.

09-21-2021 11:40 PM
by Anonymous User
Not applicable

Hello everyone,

I am having an annoying problem concerning a Feature Layer. The Feature Layer was published using a Datastore (Database) connection to a PostgreSQL Database. The publishing process worked fine and the layer got a (random?) symbology. Now I want to change that symbology.

When going into the "Visualisation" Tab of the portal item I can change the symbology and save the layer. The changes are present when I open the layer in a map viewer and also in the items JSON. In the REST interface however the "Drawing Info" does not reflect the changes I made. So when integrating the service I still get the old symbology.

I tried updating the definition of the layer using python as I did with other (but hosted) feature layers, but end in an error:

Access to admin resources are not allowed.
(Error Code: 403)

Has anyone ever had that problem and knows how to fully update the symbology? Thanks for any hints.

0 Kudos
2 Replies
New Contributor III

Dear AlexanderZeller,

When you save the layer after modified the symbology, its symbology is stored in the portal item, no in the ArcGIS Server REST service.

How are you adding the layer to your map? Adding the Feature Layer or adding the REST url directly?

If you add the item in which you save the symbology to a webmap it should maintain the custom symbology.



0 Kudos
by Anonymous User
Not applicable

Hello Borja,

The feature layer will be used via the REST Service using the JavaScript API in a third-party app.

So there is no way to change the symbology of the feature layer directly?

Thanks for your reply,


0 Kudos