Data Store (relational) 10.5 - failure during configuration

05-29-2017 07:14 PM
New Contributor III

Enterprise ArcGIS 10.5 environment.

Federated and certificates applied.

Windows Server 2012 R2

Using IWA and working as expected.

Installed ArcGIS Data Store 10.5 on a separate, dedicated VM (vmware).

When configuring the data store via https://localhost:2443/arcgis/datastore, I am prompted with the error:

Machine ‘https://<machinename>.<domain>:6443/arcgis/admin/data/registerItem’ returned an error.

‘Error registering item. Failed to encrypt the data store connection string. Please check the logs for more information’

The data store logs reveal:

FATAL: password authentication failed for user: “<username>”

The user "<username>" is the database admin user for the relational data store.

The cmd utility provides the same error.

Running the config from another client and browser produces the same error.

Any thoughts or ideas?

Update: Tile data store does not encounter this error.

4 Replies
Occasional Contributor II

We also are seeing this issue on one of our boxes - very similar infrastructure in all regards.   Were you able to figure it out @angus?  Was FIPS encryption an issue?  We are looking to check that next, and then will reach out to support.

0 Kudos
Occasional Contributor II

The root cause was the hosting server (ArcGIS Server). The hostname of the hosting server was 'arcgis' and once this was changed, the issue did not re-occur. I believe it was lodged as a bug. Check to see if the hosting machine or data store machine has a reserved word as the hostname.

Occasional Contributor II

Thanks Angus.   Yeah our hostnames do not have "arcgis" in their hostnames.  We will have to reach out to esri support.  Something very funky going on with the environment we are in, it seems.

0 Kudos
Esri Contributor

Hi J,

Did you want me to add this to our document so we can keep track of it?



0 Kudos