Create Enterprise Geodatabase hangs at 9%

223
5
01-10-2020 06:56 AM
Highlighted
New Contributor III

The tool Create Enterprise Geodatabase hangs at 9%, right after logging: "Created geodatabase tables and stored procedures." It hangs in both Pro 2.4 and ArcMap 10.7.1

Platform: Windows Server 2016

Database: Oracle 19c

I attached screenshots.

How do I get the tool to work?

-Peter

Reply
0 Kudos
5 Replies
Highlighted
Esri Frequent Contributor

Have you installed the Oracle 19c Patch (for ArcMap 10.7.1): ArcGIS (Desktop, Engine, Server) Support for Oracle 19c Patch 

You must also be at ArcGIS Pro 2.4.2; Oracle database requirements for ArcGIS 10.7.x and ArcGIS Pro 2.3 and 2.4—System Requirements | Docu... 

If so, how long has it been at 9%?

--- George T.
Reply
0 Kudos
Highlighted
New Contributor III

George, 

Yes I installed the 19c patch.

Install order:

ArcGIS Desktop 10.7.1.11595

Oracle 19c patch

ArcGIS Pro 2.4.0.19948

ArcGIS Pro hung for 40 minutes before I killed it.

I reverted the VM, then ran it in ArcMap, and I let it run overnight and it hung for 15 hours.

I'll check my.esri.com to see if I can download a newer ArcGIS Pro.

-Pete  

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Is your installation local (in the same location) as the Oracle DB?

Does the the user being used in the GP tool have all the correct permissions?

You may want to open a technical support case for this not completing so an analyst can take a look.

--- George T.
Reply
0 Kudos
Highlighted
New Contributor III

>Is your installation local (in the same location) as the Oracle DB?

Yes.

>Does the the user being used in the GP tool have all the correct permissions?

Yes, the Oracle user is the sysdba.

>You may want to open a technical support case for this not completing so an analyst can take a look.

I'll try using the latest patch for ArcGIS Pro like you suggested. If it fails, I'll open a ticket.

Thanks for the suggestions.

-Pete

Reply
0 Kudos
Highlighted
New Contributor III

I contacted Esri support. They were not able to reproduce the situation.

I reverted to Oracle 18c and used ArcGIS Pro 2.4.3. I was able to successfully create an enterprise geodatabase.

-Peter

Reply
0 Kudos