Couchdb Error in 10.6.1 Builder Environment

1451
9
Jump to solution
11-12-2018 12:17 PM
Highlighted
New Contributor II

While setting up the 10.6.1 Builder Environment for testing, everything seems to be working fine, until I let the machine set the "Register Data Stores with GIS Server".....then I get an error saying:  "Couchdb failed to start".  I've looked through the documentation....and I must be missing something?  Anyone else have this issue?

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Occasional Contributor

Hello Adam,

Please see the following BUG: BUG-000116596 ("Unable to configure tile cache data store if port 5986 is utilized.").

The Tile Cache Data Store requires port 5986 to be open and listening. The problem may be that port 5986 is not opened on your firewall or there is  another program utilizing this port.

I would first check to see if your firewall allows the port to be open. If the port is open then try the next step:

On the machine with Enterprise being deployed, check if the port is used by another program by stopping the ArcGIS Data Store service and opening a command prompt. Type the following command:

netstat -ano | findstr 5986

If that command returns nothing then there is no program utilizing that port. If it does return something trace the PID to find the program that is using the port.

Let me know if you have any questions.

View solution in original post

9 Replies
Highlighted
Occasional Contributor

Hello Adam,

Please see the following BUG: BUG-000116596 ("Unable to configure tile cache data store if port 5986 is utilized.").

The Tile Cache Data Store requires port 5986 to be open and listening. The problem may be that port 5986 is not opened on your firewall or there is  another program utilizing this port.

I would first check to see if your firewall allows the port to be open. If the port is open then try the next step:

On the machine with Enterprise being deployed, check if the port is used by another program by stopping the ArcGIS Data Store service and opening a command prompt. Type the following command:

netstat -ano | findstr 5986

If that command returns nothing then there is no program utilizing that port. If it does return something trace the PID to find the program that is using the port.

Let me know if you have any questions.

View solution in original post

Highlighted
New Contributor II

Hi Cody,

Thanks for the quick response & yes, I had an issue where WinRM was using the same ports by default.  Marco tagged the issue as well (earlier)!

Thanks again...

>>Yes.

>>See Esri BUG-000116596 ("Unable to configure tile cache data store if port 5986 is utilized.").

 

>>WinRM und CouchDB are using the same port.

>>Grüße

>>M. L. Zehner

Reply
0 Kudos
Highlighted
Occasional Contributor

I am glad to hear that you were able to figure out the root cause!

Reply
0 Kudos
Highlighted
New Contributor

Hi Cody,

I checked the 5986 port availability using "netstat -ano | findstr 5986" command. 

Its return two record with PID 4. NT Kernel & System running under PID 4.

Can you help to continue the configuration  .

Thanks.

Reply
0 Kudos
Highlighted
Frequent Contributor

Just a heads-up - I am having this same issue, too.

Reply
0 Kudos
Highlighted
Occasional Contributor

Hello,

So in order to isolate the exact program that it using that PID you will most likely have to run the following command:

  •    netstat -nab | findstr 5986

This command should show the name of the program utilizing the port.

Reply
0 Kudos
Highlighted
New Contributor II

Here is a workaround supplied by Esri, related to BUG-000116596. We ran into this issue recently, and the workaround solved the problem for us:

1. Delete the listener on http and https:
winrm delete winrm/config/listener?address=*+transport=HTTP
winrm delete winrm/config/listener?address=*+transport=HTTPS

2.  Configure ArcGIS Data Store Tile Cache

3. Enable again:

winrm quickconfig -transport:https
winrm enumerate winrm/config/listener

4. Check whether Couchdb still runs

Reply
0 Kudos
Highlighted
New Contributor II

A simple powershell

Get-Service WinRM | Stop-Service

Will stop WinRM from listening on the aforementioned port and is another simple Start-Service will restart it.

Enjoy.

Reply
0 Kudos
Highlighted
New Contributor II

I absolutely had this same issue last September.  In our case our Server Admin Team is using Solarwinds Enterprise Management System.  One of its functions is to monitor HTTP and HTTPS traffic on remote servers.  It uses Microsoft WinRM to listen for that traffic, which others in this thread have described.  WinRM uses port 5985 for HTTP and port 5986 for HTTPS traffic.  I had a support case opened for this last fall and the Support Tech associated the case with these BUG reports BUG-000116597 and BUG000116596.  In my case, I was able to work with our Server Admin staff to direct Solarwinds to use an adjacent port (5987) to do it's work.  I did receive BUG resolution report for 00116596 on April 16th, they are planning to add this port to the Data Store installation documentation at ver 10.7.1.  I just checked and they have not yet added it in 10.7 online documentation  They have no current product plans to make accommodations for the fact that Microsoft is already using port 5986 in WinRM 2.0.  My hope is the documentation edit includes the reference to the conflict with WinRM.  For anyone else encountering this issue, here's the URL to the Microsoft documentation - https://docs.microsoft.com/en-us/windows/desktop/winrm/installation-and-configuration-for-windows-re...

Reply
0 Kudos